Blackboard Vista requires that your browser conforms to certain standards. If you have an out of date or unsupported browser, you will need to download either a compatible version of your current browser or a compatible browser before attempting to log into Blackboard Vista. If you need assistance determining if you are using a compatible web browser, click the appropriate operating system logo below.

required required
Browser: Firefox latest stable release Browser: Firefox latest stable release
Internet Explorer 8 Safari 5
Internet Explorer 7 Safari 4