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Tutorial Outline

= Image Format Types = Macros
= Raster Images = Recording and running
= Raster Image Quality = Writing your own
= Measurements
= Getting Started with ImageJ * Area and dimensions
= Opening and saving images = Histograms
= Selections and cropping * ROl and masking
= Image Adjustments = Thresholding

Quantification of intensity
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Raster Image Files

= Raster image files are composed of a grid of pixels.
= Each pixel contains color or intensity information

= File formats support many types of raster image
= 24 bit full color — RGB (8 bits per color) — png, tiff, rgb, bmp, jpg, jp2
32 bit full color with alpha — png, tiff, rgb, bmp, jpg, jp2
8 bit color map — gif, tiff, rgb
Bitmap (black and white only) — tiff, bmp.
Grayscale — can be 8,16, or 24-bit — png, tiff, bmp, jpg, jp2

I

UNIVERSITY 8 bits each color at each pixel



Bits
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# of bits per pixel Range of intensity

(N) levels
(0 > 2N-1)
8 0 - 255
10 0-1023
12 0 - 4095
16 0 - 65,535
24 0-16,777,215
3x8 0 - 255 per channel
4x8 0 - 255 per channel

Image Type

grayscale

grayscale
grayscale
grayscale
grayscale
RGB

RGB with alpha

Computer
Representation

(C types)
unsigned char (8 bits)

unsigned short (16 bits)
unsigned short (16 bits)
unsigned short (16 bits)
unsigned int (32 bits)
unsigned int (32 bits)
unsigned int (32 bits)

The number of bits determines the number of intensity levels that can be digitally

encoded.

For non-power-of-two bits per pixel the image is usually stored in the next higher-up pixel

format.

= Example: 10-bit image stored as a 16-bit TIFF. Only values 0-1023 would be used.



What sets the # of bits and pixels?

= The physical device capturing the image sets the number of pixels
= The electronics that convert light intensity to an electronic signal sets the number of bits.

232 | 172 234 | 255

v -] . -] .
“ 209 | 119 198 | 222

187 | 155| 162 | 188

206 | 178 | 195 | 245

The image as Pixel (spatial) Charge levels are read out 8-bit digitization assigns the
projected onto resolution set when by a digitizer with a fixed values shown.
the CCD chip. chip is manufactured. number of bits per pixel.

Charge accumulates Charge levels over the

per pixel during maximum bit value are

exposure. saturated.

BOSTON
UNIVERSITY



Color Acquisition

= Colorin an image can be acquired in
many ways. Here's 2 out of many.

= An RGB CCD or CMOS chip has 4
sub-pixels per pixel of spatial
resolution that detect red, green, or
blue

= A filter wheel is used to select a range
of wavelengths, and multiple images
are taken with a monochromatic chip.
= RGB images use 3 separate acquisitions
= “‘R”“G” “B” bands are user-selectable.

= More than 3 bands can be used for a multi-
spectral image.
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Factors Involving Raster Image Quality

Resolution: the number of pixels in the image (width x height) \

DPI: Dots per Inch s &
= A term for printing where dots of ink are physical printed to a page

PPI: Pixels per Inch is the digital equivalent
= The number of pixels in an inch (as on a monitor)

DPI and PPI are often used interchangeably <1952

€214 >

Number of available colors in the image format.

Anti-aliasing: Essentially a blurring operation that is done to smooth images and graphics
when they are re-sized.

Compression
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1134, RGB |

Compression and Image Quality

= Compression in image formats saves size on disk
= Compressed images take longer to open and save

= Lossless compression:
= PNG format, TIFF, JPEG2000, others
= Does not alter the image

= A ZIP file is a non-image example of lossless compression Size (bytes)

= Lossy compression: TIFF 2,891,854
= JPEG format, GIF, JPEG2000 (careful!), others
= Discards information from the image PNG 2,630,062
= Much smaller file sizes than lossless compression
= Greater the compression, lower the quality JPEG 220,517
= Not suitable for the storage of scientific images!! (77% quality)

JPEG 449,654

(95% qualiy)



JPEG Compression h F h

JPEG Quality: 95% 50% 15%

Original

Orig — JPEG:
Same B&C)

= The JPEG algorithm compresses an image by removing detail from the image before
performing a lossless compression

= High-frequency information is discarded
= Sharp transitions in contrast

BOSTON .
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Outline...
/' Image Format Types = Macros
v = Raster Images = Recording and running
v = Raster Image Quality = Writing your own
= Measurements
= Getting Started with ImageJ " Area and dimensions
= Opening and saving images " Histograms |
= Selections and cropping * ROl 'and masking
= Thresholding

= |mage Adjustments

Quantification of intensity
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ImageJ

= Home page: hitps://imagej.nih.gov/ij/

ImageJd is a public domain, Java-based image processing program developed at the National

Institutes of Health. ImageJ was designed with an open architecture that provides extensibility
via Java plugins and recordable macros. (from Wikipedia)

Notable features:

= Written in Java and runs on many platforms: Windows, Linux, Mac OSX, and more

= Supports reading & writing a wide variety of image formats

= Many built-in image processing tools

= Can be programmed using a built-in macro system or scripts written in a variety of languages
* R, Python, Java, and more

= Your own custom code can be added to your ImageJ install as a plugin and used like any
other program feature!
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https://imagej.nih.gov/ij/

.
Fii

= Fiji Is Just ImageJd: http://fiji.sc/

= A version of ImageJ that is pre-packaged with a large number of plugins
and macros.
= More convenient to set up than ImageJ

= The plugins, macros, and additional tools are oriented towards analysis of cell and other
biological samples.

= |n this tutorial we'll use Fiji
= Recommended for most people in bio-related fields
= The terms Fiji and ImageJ will be used interchangeably for this tutorial.
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http://fiji.sc/

Starting the program Fi shorteut

{
= Open up Imaged pi
= On the training terminals double click on the SRRl
shortcut;

= RCS Tutorials - ImageJ - ImageJ shortcut

ImageJ shortcut

= A small tool and menu window will open:
(Fiji Is Just) Image! — O x Fd
File Edit Image Process Analyze Plugins Window Help |.|:I.I.IEI.!;JJ
B ojc|o|A2 |\ Ala| o) wfsw]s]/]a] |» s
(Fiji 1s Just) Imaged 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];
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[ BU_Fitrec.png (75%) — ] X
1280x975 pixels; RGB; 4.8MB
ESEER

Opening Images

\Iﬁr {Fiji Is Just) Imagel —_ 0 %

ﬂe Edit Image Process Analyze Plugins Window Help
5 O] x| o] << s3]\ Al & [ @] oofsufun] 0| 4] 8] |=
(Fiji Is Just) Imaged 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];

= Under the File Menu, choose Open, then
navigate to the tutorial images directory, and
open the file BU_Fitrec.png

= RCS Tutorials - ImageJ - Tutorial Images

= Drag n’ Drop onto the window will also open
Images.

Ctrl- - (“control hyphen”) | Zoom out

Ctrl -= (“control equal®) | Zoom in
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Tools

(Fiji ls Just) Imagel — [ >
File Edit Image Process Analyze Plugins Window Help
E@,‘E‘@‘f’:‘i ii’f_ﬁ\‘ﬂ‘@\‘@?‘ ‘ EthStk?LUTT;?‘j"‘@q‘ ‘::::
(Fiji Is Just) ImageJ 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];

= A bunch of tools are visible by default.

= Place the mouse cursor over a tool to see its name. The little red triangle

means a right-click will select a different tool option. Many can be double-
clicked to see a configure window.
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Magic Wand
TOOIS agie wvan Color picker
Zoom
(Fiji ls Just) Imagel — [ >
File Edit Image PFDEESS malyze lugins Wlndnw Help

ao

(Fiji Is Just) ImageJ E.D-EI rLAE1-“ 51n J:aw 1.6.0_ 64§ [64- blt]-

\ ; \ S_— )
Y _ Text Menus Paint tools
Selection Angle tool |
tools Scrolling
| = Go ahead and try them out!

= Ctrl-Z will undo changes.

Multi-point
and point = You can always close the image and re-
tool open it to start over.

= Or choose Revert (Ctrl-R) from the File
menu to re-open the image.



(Fiji Is Just) Imagel - O pt
g8 Edit Image Process Analyze Plugins Window Help

New Al @|F ofswur] o] 4| a] |

Saving Images

Open Next Ctrl+Shift+0

Open Samples FOTiff..
Open Recent H Gif...
. . . Import o Jpeg...
= File Menu - Save will default to saving your RS
i Close Ctri+W ge-..
output as a TIFF file. Close Al Cirl+Shift+w | 2P
Raw Data...
- - . Save Ctrl+S
= File Menu - Save As provides a wide range image Sequence..
of options Revert Cier | AVL-
BMP_..
Page Setp..
Print... Ctrl+P PGM._
Export FOFTS..
Quit e
Selection...
Fix Funny Filenames XY Coordinates. .
Make Screencast Results. .
Text...
Analyze. ..
MHD/MHA ...
MHD/MHA compressed ...
DF3 ...
Mrrd ...

ICO ..
BOSTOIN
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HPM ..




Selections and Cropping Images

[ BU_Fitrec.jpg - O
451x448 pixels; RGB; 789K

= Use the selection tools to select an area of the image (circular, rectangular, etc.)
= Hold the Shift key to do multiple areas.

= Choose the menu option Image - Crop
= The image will be cropped to the minimum bounding box on the selection.

BOSTON
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Histograms

\ =PRSS [4" Histogram of BU_Fitrec — O * [4 Red Histogram of BU_Fitrec — O
| 421 3 pixels; RGB; 684K

300x240 pixels, RGE; 281K 300x240 pixels;, RGE; 281K

0 255 0 255
Count: 24505 Min: 0 Count: 24505 Min: 0
Mean: 124 545 Max: 251 Mean: 147 672 Max: 255
StdDev: 45.215 Mode: 159 (644) StdDev: 50.751 Mode: 183 (684)
| List | Copy | Log | Live | RaB | THTEETE List | Copy | Log | Live |fREE] T
’ count=5 count=5284
= Select an area. = Click the Live button and drag your
= Click Analyze>Histogram or press Ctrl-H selection around.
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[T (Fiji Is Just) ImageJ - | X

Image
A dj u S tm e n tS EBE'E Process Analyze PIU.QHSD Tlejztk'rj; , | /l R | l N

Show Info... Ctri+l | Window/Level...
Properties... Ctrl+Shift+P | Color Balance...
Color »  Threshold... Ctrl+Shift+T
. Stacks » Color Threshold...
menu has a number of options Crop Ctivshiftex | Canvas Size..
h lor | IS, | Duplicate..  Ctri+Shiftep | e Width...

'[O C an g e CO OI’ eve S, Im ag e Hertatic Coordinates...

size, app|y th resh0|ds, etc. Scale... Ctr+E | Auto Threshold
Transform » | Auto Local Threshold
Zoom » Bleach Correction
Overlay »  Auto Crop
Lookup Tables ,| Auto Crop (guess background color)
Ao S Scale to DPI =
Drawing 4
Video Editing 4
Axes 3
Convert
Convolve
Threshold 4
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Brightness/Contrast

= Choose Image - Adjust = Bright/Contrast
= Or use the key combo: Ctrl-Shift-C

= Move the sliders or use the Set and Auto
buttons to change the display.

= The Apply button will change the pixel values in
the image.
= Save the image to make these changes permanent.

BOSTON
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: Auto 4 Reset

Minimum

Maximum

|

Brightness

|

Contrast

Set Apply

Ctrl-Shift-C

Open B/C control



(Fiji Is Just) Imagel = O X
File Edit Image Process Analyze Plugins Window
Help ELQTG‘@‘-{‘A g ”\‘A‘O\‘ﬂ‘m‘ Dwv|5ﬂ ImageJ) Website...

Pencil Tool ImageJ News. ..

Documentation...
Installation...

Mailing List...

Dev. Resources...
Plugins. ..

Macros...

= The Help menu has extensive documentation on every part of ImageJ/Fiji. Macro Functions...
= |If you are not sure how to do something, start here! Examples »

= The Documentation option has a number of tutorials that guide you through
a variety of typical tasks.

Update Imaged. ..

Refresh Menus

About Plugins r
About Imaged....

Report a Bug
Help on Menu ltem
Switch to Modern Mode

Update...

Upload Sample Image...
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= Figure width 2.25 or 4.75 inches.

DPI vs. PIX6|S = Line art (graphs, etc.) must have at least 300

DPI resolution.
= Grayscale and color images must have at

= Journals will typically request images in 300 least 300 DPI.
(or higher) DPI resolution with a specified = Up-sampling artwork (artificially increasing
image size in inches. file size or resolution) is not permitted
= Vector illustrations and diagrams (preferred):
= As an example, the journal Science has the = .PDF, .EPS, Al
following specifications in its instructions: —< = Raster illustrations and diagrams:
= http://www.sciencemag.org/authors/instructions- = TIFE

preparing-revised-manuscript

= Vector and raster combinations for
photographs or microscopy images:
= PDFor.EPS

= Raster photographs or microscopy images:
= TIFF

= Keep your original images in case they’re
ever requested.

BOSTON I
UNIVERSITY


http://www.sciencemag.org/authors/instructions-preparing-revised-manuscript

DPI vs. Pixels Example

= Congratulations! Science wants to publish your article.
= You want to include a fluorescence microscopy image in your manuscript.
= The journal wants at least 300 DPI and a width of 4.75 inches.

= What should the pixel resolution should you use to meet the
requirements? (DPI| €<-> pixels per inch aka PPI)

= Minimum spec of 300 DPI: 300 dots per inch X 4.75 inches = 1,425 dots (pixels)

wide.
= QOverachiever spec of 600 DPI: 600 dots per inch X 4.75 inches = 2,850 dots (pixels)

wide.
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DPI vs. Pixels Example x

X Scale: l—i
= Using the 600 DPI target and 4.75 inch width. e |
Width (pixels). |2830
Height (pixels). |2850
= High res image: 4096x4096 pixels / interpolation: [None 7]
= Resize image to 2850x2850 pixels. Save in the TIFF file format. I Fil with background color
= Average when downsizing: does some averaging to reduce S
resizing artifacts. Recommended to select this. o ”evﬁw'nld:ﬁ
.. |scaled_image.png
= Interpolation: Select an algorithm. Bicubic will usually give the e
best results at the slowest speed. oK | Cancel |
= The image will now be able print at the correct width without
changes. Ctrl-E Open resize tool

BOSTON
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DPI vs. Pixels Example x

XScale: |-
= Using the 600 DPI target and 4.75 inch width. vecae |
Width (pixels): lﬁ
Height (pixels): [2850
= Low res image: 256x256 pixels " nterpolation: [Noms 7]
= Resize image to 2850x2850 pixel. Save in the TIFF file format. S
= Average when downsizing: Has no effect when scaling up. v ietage wher downsizing
= Interpolation: Careful! The requirements are for upscaling only pcreat_e ”e“i;“;‘:lizwimage_png
with no upsampling (interpolation). Choose None for this journal. e i
= The image will now be able print at the correct width without oK | Cancel |
changes.

Ctrl-E Open resize tool

BOSTON
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Upscaling & interpolation

= None: Copies pixels into neighboring spots.
= Will look “blocky” with large amounts of upscaling.

= Bilinear: Fits straight lines through 4 neighboring
pixels and interpolates

= Bicubic: Fits a 3" order polynomial to 16
neighboring pixels and interpolates

=  QOpen 5x5.tif and let’s try this out.

25x25 8-bit
5x5 8-Dbit No interpolation

<o

BOSTON
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https://en.wikipedia.org/wiki/Bilinear_interpolation

Bilinear \/ Bicubic

Adds new points: upsampling!

25x25 8-bit 25x25 8-bit
bilinear bicubic




Plot of 5x5 - O >
4 T1x325.12 pixels (530x258); 8-hit; 132K

200
5¥5 pixels; 8-hit; Ok -

Gray Value

1001

v

s

0 o R I L
] 1 2 3 4
Distance (pixels)

Mare =

Live | ¥=2, Y(X)=202

List | Save. .

= Zoom into 5x5.tif with Ctrl-+

= With the box tool, select the middle row of pixels.

= Choose Analyze->Plot Profile or Ctrl-k to see a profile plot of the middle row.

= Click in the image to undo the selection (or Ctrl-Shift-A)

= Open the resize tool with Ctrl-E. Increase to 25x25 pixels, pick an interpolation method,

BOSTON add a box, and plot its profile.
UNIVERSITY



300 T T 1 T
Profiles for each resized image
q o0— 60— 0o o—6—606—0
250 - —
S o—6—0
@
“ o O O
200 uy/;,\\\\ —
‘a ® @
> \
2 Q Y R\
] \
€ 150 - 1o \, ]
E, / ‘*\ @
a3 //
& y
b
100 |- i
K D
”r' \'XI‘
& \\
& \® —O— bilinear
50 - \ ) —O—none | ]
2/ . ~©- bicubic
& MRS
\\m’ 1\
(NS \ /
0 fa fa o | A o o |
0 5 10 15 20 25

horizontal pixel

= The profile data was extracted for each resized image using the List button in the lower
left of the Plot window.

= |tis important to understand what image algorithms are doing mathematically to your
BOSTON : .
image before applying them!



8-bit images

Open another image file, Citgo_Sign.tif

Hover your mouse over part of the image. The x-y
location and pixel values for the RGB channels will
be displayed in the lower let of the main window.

This is a 8-bit image so the value range is 0-255

When displayed, every grayscale image has a
colormap as you're using an RGB display!

Display the colormap: Image-> Color - Display

I (Fiji s Just) Imagel
File Edit Image Process Analyze FPlugins Window Help

<

Eo

|~ &

+ty
++_

Nalae

‘ D@r‘Sm‘luT

4

d >

4]a] |>

x=186, y=143,

/

value=105

[ Citgo_Sign.tif
675x450 pixels; 8-bit; 297K

[ Look-Up Table
326x188 pixels, RGB; 239K

255

LUT
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Direct 8-bit

Sepia LUT

BOSTON
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Choose some other LUTSs:

—

[ (Fiji Is Just) Image

0 o|x|o|~|4

— O
File Edit Image Process Analyze Plugins Wimelp

+++
s

N |A] o] 2| esu]uf 0] 4]0

|}}

*=186, y=143, value=105

cool LUT

Green Blue Fire
LUT

Remember this just effects the
display, not the image on disk
which remains an 8-bit
grayscale image.



Color Images

= |mageJ supports two types of color images, RGB
and composite.

= RGB images are standard color images.

= E.g. pictures from your smartphone or a three-color CCD or
CMOS detector

= Composite images are sets of grayscale images
that are assigned colormaps and then combined
to form an RGB image.

RGB
image

BOSTON
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Stacks and Hyperstacks

= |maged handles 4 dimensional images using a stack.
= The 4t dimension can be time or wavelength channel.

= Example 1. A set of grayscale microscope images taken over several minutes (grayscale
video)

= Example 2: A set of grayscale images acquired with different wavelength filters and a filter
wheel.

= Example 3: An RGB image
= A hyperstack adds a 5™ dimension

= Example 1: A set of grayscale images acquired with different wavelength filters with multiple
time steps per wavelength (multispectral video).

= Example 2: A set of RGB images acquired over time (color video)

BOSTON
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RGB images

= QOpen the image tetraspeck.tif. These are ThermoFisher
fluorescent microspheres.

= Convert this from an RGB image to a 3-channel stack:
= |mage->Colors—>Split Channels
= |mage->Stacks—>Images to Stack

= The scrollbar switches between slices in the stack.

= Press Ctrl-Shift-C to open the B&C control. Each
slice gets the same B&C setting.

= Hold the Shift key when moving between slices —
this will do the Auto B&C command for each slice.

BOSTON
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Merge Channels >

C1(red) |C1-Composite -

Back to RGB cocrom [eroomron ]

C3 (blue) |C3-Composite =
C4 (gray) |*Mone* -

Ch (cyan): IW'
o _Convert the stack back to a set of AP
I m ag eS : C7 (yellow) |*Mone* O X

= Image->Stacks-> Stack to Images - creamposte
= Click on each image and choose the

matching LUT (Red for the red image,
etc.)

= Re-create the RGB image:
= |mages->Color->Merge Channels
= Check Keep source images

= The RGB image will open alongside the
other 3.

BOSTON
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4

1

I~ Ignore source LUTs

LOK | cancel




Composite Image

= Open Rat_Hippocampal Neuron.tif
= This is a Fiji sample image
= This is a 4-channel fluorescent image with a white
light image.
= The per-channel LUT information is stored by
ImageJ in the TIFF file header.

= Choose Image—->Color->Channels Tool

= Choose Composite and try the options.

= Click More — try creating an RGB from your
composite.

= Now choose Color, then click More.
= Here you can change the LUT per channel

BOSTON
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[5% Channels

' Rat_Hippocampal_Neurontif

|Composite v]

v Channel 1
[V Channel 2

.............................

.............................

[V Channel 4
¥ Channel 5

Ctrl-Shift-Z

Open channels tool




Outline...
/' Image Format Types = Macros
v = Raster Images = Recording and running
v = Raster Image Quality = Writing your own
= Measurements
=/ Getting Started with ImageJ " Area and dimensions
¥'= Opening and saving images " Histograms
v'= Selections and cropping * ROl and masklng
/= Image Adjustments = Thresholding

Quantification of intensity
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Macros

= |ImageJ macros can be saved, edited, assigned to keys, and shared
amongst friends.

= The macro language is straightforward and supports all the built-in ImageJ
commands

= This gives users the ability to create re-usable image processing
programs without having to learn a language like R, Python, or Java.

= Choose Plugins>Macro->Record

= The window that opens will now record your commands.
= Leave it open!

BOSTON
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Sample fluorescent image measurement JL
K (|

2048x2048 pixels; RGB; 16MB

Maximum

]
]

Brightness

= Openimage TinR-A555-Rab11-A647-341-
01.tif
= Provided by John Chamberland of BU
= The red is transferrin receptor, a carrier protein
= The greenis Rabll, an enzyme

= |maged to investigate when these molecules are
colocalized.

Contrast

Reset

Apply

= Adjust the B&C as you like (don’t press Apply)

= We will measure the intensity, location, and size of
the red fluorescent transferrin receptors.

= Re-open (Ctrl-R) to undo any B&C settings

BOSTON
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Red Channel

= Strategy:
= Remove the background (out of plane light)

= Segment the red channel image into separate blobs for
measurements.

= Make the measurements on the original red channel image.
= Save the measurements to a file.

= Split the RGB image into separate channels:
Image->Color->Split Channels

= Close the green & blue channels

= Click the Red image. Click Image->Duplicate to
make a copy in a new window. We’ll do our work
on the new copy and final measurements on the
original.

BOSTON
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Background ~ |

2048x2048 pixels; 8-hit, 4MB

= Adjust B&C again.
= Click Process-> Subtract Background

= Apply a 12 pixel radius rolling ball subtraction

Subtract Background... >

Raolling ball radius: m pixels

[ Light background

[ Create background (dont subtract)
[ Sliding paraboloid

| Disable smoothing

[ Preview

] | Cann:el| Help|

= Note that there are many other ways to do a
background subtraction...

BOSTON
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Rolling Ball Background Subtraction

= A widely used technique

= A ball of radius R is “rolled”
across the image and it
position is tracked (red line)

= The position is then subtracted
from the image, removing the
background.

BOSTON
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Figure 1 from A novel method to remove the background from x-ray diffraction signal
Yi Zheng et al 2018 Phys. Med. Biol. 63 06NT03 doi:10.1088/1361-6560/aaac9e




Thresholding

Threshold

*

r—

5.20 %

2] [2]

| 2ss
»| zss

|0tsu

=] |Red

=

Rab11-AB47-341-01-1.tif (red)-1 (33.3%)

els; B-hit {inverting LUT); 4MB

| DO an Other auto B&C Iv Dark background [ Stack histogram 'P' . ‘ _’,:El’,-:’}: , ;-:"Er'.}_;_ _g.‘.-*”' -?"f, ;--‘j +

Auto | Apply | Reset | ﬂ A ..;g'f:'w'.

= Now apply a threshold to select Vi L
brighter regions e e YR
: : L DA LIPSy SN
= Click Image—>Adjust->Threshold o R I iU
:':'- . ;.'ﬂ':.d I"J‘ ! v ', > :n::; “:"_Pf...,‘:' : '
. R ‘o " ® A
= Which threshold to use? RN, S e

= Try afew! . o frs ’ ij.j’:';-r":: ..

= Choose the Otsu threshold, click RAIDISER 7 P
. re, - - y 1.:“;'_,._,_"‘:'_, __-.,. L ',' T ':-.
Apply, close the threshold O DA ST A R A

window. R R A WACTR
o : iy - T ) 'I-,r'.
* T s . - »
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Analyze Particles >

Size (pixel*2). |4-2500
C re ate R O I S Circularity: |EI.EII:I—1.EIE|

Show:  |Nothing |
* ROI: “Region of Interest’ e o
= |mageJ can handle many ROIs at e
once using the ROl Manager tool. ok | [Gareet | [1es |

= Click Analyze->Analyze Patrticles.
= Set the size to 4-2500

RO.. — O X
= Set Show to None 0010005 1] s
: 0003-0001 il
= Uncheck evel‘ythlng but Add to 0004-0004 Delete
0005-0004 Rename...
Manager 0006-0004 Measure
_ 0007-0002 ————
" CIICk the OK bUttOn. gggsgggj Properties...
i 0010-0002 Flatten [F]
= The ROI manager will open. ovt1 000 ore -
0013.0004 W Show All
0014-0006 ~ | Labels




Measurements

= Click the original red channel image.

= |n the ROl manager, click in the list of
ROIs and press Ctrl-A to select them
all.

= Click the Add button.

= Uncheck the Labels option.

= The ROIs will be highlighted in the
original image.

= Click Analyze-> Set Measurements,

choose some measurements to make.

BOSTON
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ROl Manager — O ot
0001-0003 ; Add [t
0002-0002 1=
0003-0001 Update
0004-0004 Delete
0005-0004
Q006-0004 Rename...
0007-0002

Measure
0008-0004
0009-0007 Deselect
0010-0002 .
0011.0005 Properties...
00120015 Flatten [F]
0013-0004
0014-0006 LTS
0015-0002 W Show Al
ﬂﬂ'lﬁ-ﬂﬂng remeeemeeem——— .
0017-0005 - iLabels:

Set Measurements *

W Area [idean gray valug,

[~ Standard deviation |~ Modal gray value

[~ Min & max grayvalue [ Centroid

[+ Center of mass I~ Perimeter

[ Bounding rectangle [ Fitellipse

[~ Shape descriptors | Ferets diameter

I¥ Integrated density [ Median

[ Skewness I Kurtosis

[~ Area fraction I~ Stack position

[~ Limitto threshold [ Display label

[ InvertY coordinates [ Scientific notation

[~ Addto overlay [~ MaM empty cells

Redirectto: |None |

Decimal places (0-9): |2

0K | Cancel| Help|




Fle Edt_ Font Resuls

Measurements cont'd e mm I
= |n the ROI manager, click the

Measure button. oo pmImoaem wn e =
= This will measure all ROIs :

separately.
= Click Analyze->Measure to measure | ‘

all the ROIs as a single area L

= Measurements will be displayed in a
new window.

= The measurements can be saved or
copied using the File and Edit
menus.
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Macro window

= |t should look something like this:

" Recorder

Record: |Macro - | MName: |f--'|E|E:rU.ijrr1

Create ﬂ

= Close all of your windows except the
macro recorder.

= Click the Create button. The full macro
editor will open.

= (Close the macro recorder.

= Click the Run button. What happens?

= Try the file fluorescence.ijm
= Open the image, run that cleaned-up macro.
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v

run {"5plit Channels™);

selectWindow ("TfnR-A555-Rakbll-Ae47-341-01.tif
selectWindow ("TfnR-AS55-Rakbll-A647-341-01.tif
selectWindow ("TfnR-A555-Rabll-A647-341-01.tif
selectWindow ("TfnR-A555-Rakbll1-A647-341-01.tif
close();

selectWindow ("TEnR-A555-Rakbll-A647-341-01.¢if
close();

selectWindow ("TfnR-AS555-Rakbll-A647-341-01.tif
run{"Duplicate...™, ™ "):
S/run{"Brightness/Contrast...™)

run {"Enhance Contrast™, "saturated=0.35");
run {"Close™) ;

run {"Subktract Background...", "rolling=12");
S/run{"Brightness/Contrast...")

run {"Enhance Contrast"™, "saturated=0.35");
run {"Close™) ;

sethutoThreshoeld ("Default dark™):
S/run{"Threshold...™)

setiutoThreshold ("0tsu dark™):;

S /3etThreshold (12, 255);
setlption("BlackBackground™, false);

run ("Convert to Mask™);

run {"Close™) ;

run {"Analyze Particles..."):

run {"Invert™)»

run {"Undo™) »

{Blus)™):
{green) ") :
{red)™)»

{green) ™) ;

{Blus)™);

{red)™):

run {"Analyze Particles...™, "3ize=4-2500 add™):

selectWindow ("TfnR-A555-Rakbll1-A647-341-01.tif
roiManager ("Select™, 3);

run{"Select A11");

roiManager ("Select™, newhArray

{red)™)»

{0,1,2,3,4,5,¢,7,8,9,10,11,12,13,14,15,1¢6,17,18, 19,20, 21,22, 23, 24, 25, 26,27, 28,29, 3
0,31,32,33,34,35,36,37,38,39,40, 41,42, 43, 44, 45, 46, 47, 48, 49,50,51, 52,53, 54, 55,56, 57

,58,59,80,61,62, 63,64, 65,66,67,68,€9,70,71,72,

73,74,75,76,77,78,79,80,81,82,83, 84,

85,86,37,33,89,90,91,92,93,94, 95, 96,97, 98,99,100,101,102,103,104,105,106,107,108,1
ge,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,126,127,128,129
,130,131,132,133,134,135,136,137,138,139,140,141,142,143,144,145,146,147,143,1439,1
50,151,152,153,154,155,156,157,158,159, 160,161, 162,163, 164,165,16¢6,167,163,169,170
,171,172,173,174,175,17¢,177,178,179,180, 181,182,183,184,185,186,187,188,189,150,1 w




Macros — :

= The macro editor can save your macro, |fe & Lewuee Tempiates Run Tools Tabs
. . *Macro.ijm.ijm
and you can run it any time.

iManager("Select”, newArray(®e,1,2,3,4,5,6,7,8,9,1@,11,12,13,14,15,16,17,18,19,28,21,22,23, 24,25, 26,2~
iManager("Select™, 4);
i iManager("Select™, @);
14 run(“Select All"ﬁﬂ
iManager("Select™, newhArray(®,1,2,3,4,5,6,7,8,9,1@,11,12,13,14,15,16,17,18,19,28,21,22,23,24,25,26, 2
iManager("Measure");
iManager(“Select™, 1513);
n{"Undo™);

n{"select AL1");

iManage Select”, newtrray(e,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,28,21,22,23,24,25,26, 2
Select™, 1513);
Show Mone");
Show A11");

e E |
c o Q0

= This allows the exact same process to
be applied to multiple images.

e e B |
cC C QO Q0 Q

_[u
iManager("
Manager("
Manager("
54 iManager(“Select™, 152@8);
55 run("Select Al11™);
~oiManager("5elect”, newirray(e,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,208,21,22,23,24,25,26, 2
iManager("Show All without labels");
53 roiManager("Select™, 1513);

59 run("Select A11™);

iManager("Select”, newArray(®e,1,2,3,4,5,6,7,8,9,1@,11,12,13,14,15,16,17,18,19,28,21,22,23, 24,25, 24, 2
iManager(“"Measure™);

= To prepare a macro for use with the 5
Process—>Batch—=>Macro command J ust = R .,.. .................. B mhs“owmm .................. C |ea, .......
edit out any image opening and closing
commands — that will be done
automatically.
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e M| 13
cC O Q0 Q Q Q

= Process->Batch->Macro will apply a
macro to a directory of images.

1 1
0 Q Q

i
o Q




| £ Imagel Updater — O >
Addi Pluql
g g Mame | Status/Action Update Site
plugins/BAR_.jar Instal it BAR
| Manage update sites Apply changes | | Advanced mode | | Cancel |

Click Help>Updates

= Click the Manage Update Sites button

= Click a site or too, then click the Close button.
= New plugins can now be installed.
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1119x870 pixels; RGB; 3.7MB

Measuring Images
Example 2

= Open banana.png

= Click the straight line tool, then
draw a line between some of
the centimeter marks on the
ruler.

= Choose Analyze->Set Scale.

= Set the Known distance to the cm’s

[U7 Set Scale *

Distance in pixels: |ElEEekE

known distance: |1.DD
yOU Choose' Pixel aspect ratio: |1.D
= Set the Unit of Length to cm Unitoftength: [om
= Press Ctrl-Shift-A to remove the I o e Scale |
Global
line.

Scale: 50.8334 pixelsicm

BOSTON OK | Dancell Helpl
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Measurements cont’d

This is an RGB image, choose
Image->Type->8-bit to convert it.

= The background is uneven.
Process—> Subtract Background and enter

250 to do a rolling ball subtraction. \

= Ctrl-Shift-C to adjust B&C if you like.

= Draw a rectangle around the banana and
choose Image—->Crop
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Subtract Background... *

Ralling ball radius: E pixels

[ Light background

| Create background (don't subtract)
[~ Sliding paraboloid

[ Disable smoothing

[ Preview

Ok | Canu::el| Help|




Measurements cont’d

Thresholding: Pick a pixel value V.

= Pixels >=V - assign max value
= Pixels <V - assign zero value.

= Using a statistical threshold is much more
reproducible than selecting thresholds by
hand.

= Image—->Adjust->Threshold Click Dark
background. Select a few, see what
happens.

= Choose Otsu and click Apply. Close the
Threshold window.
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Red indicates value below the threshold.

| e
4 | »| =2ss

|Otsu =| |Red x|

I Dark background | Stack histogram

Auto | Apply | Reset | Set |




Parameters >

This plugin perfarms morphology operators on graylevel images

M eaS u re m e n tS CO nt, d Radius of the structure element (pixels): [5.5

/ Type of structure element | circle v|

= Fill in the holes in the banana with St
Process->Morphology-> Gray
Morphology 2| ool

= Apply a close with a radius of 5.5 pixels. -

= The close applies a dilation followed by
an erosion.

= For details on erosion and dilation see:
http://micro.magnet.fsu.edu/primer/java/digitalim
aging/processing/erosiondilation/
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http://micro.magnet.fsu.edu/primer/java/digitalimaging/processing/erosiondilation/

Analyze Particles 4 File Edit Font Results File Edit Font
[area [wean [min [Max [intDen RawintDen j Slice [Count [Total Area [Average Size [%Area |Mean [intDen | B
1 §2.847 255 255 285 21049500 54373315 banana png 1 82.547 82.547 31.697 235 21049.500
. . 5 3
= Now use Analyze->Analyze Size (cm"2) ‘ '
. ) Drawing of banana.png - 0 x
[ Pixel units 21.92x11 88 cm (1116%605); B-bit, 659K

Particles
= Under Size enter 1

= Check Display Results and
Summarize
[ Clear results [ Include holes

= Choose Outlines under Show. P [ Recon Skats
v Addto Manager | Insitu Show

Circularity: |EI.EIEI—1.EIEI

show: [Outlines R

v Display results [ Exclude on edges

0K | Cancel| Help|

= More measurements can be
set: Analyze—> Set
Measurements
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Macro window

= |t should look something like this:

Recorder — O

Record: |Macro »| Mame: |Macro.ijm Create| ﬂ

>

= Close all of your windows except the
macro recorder.

= Click the Create button. The full macro
editor will open.

= Close the macro recorder.
= Click the Run button. What happens?

= The macro editor can save your macro,
and you can run it any time.
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v

open ("Ci\\Users\\bgregor\\Documentsy\RC5 Tutorials‘\\Introc to Imaged\\Images
“whanana.png™) s

gelectWindow ({"banana.png™) ;

setTocl("line™);

makeline (31, ©¢d4, €62, &€80);

run{"Set Scale...”, "known=1Z unit=cm™);
makeline (615, 228, €15, 22&);

makeline (615, 224, €15, ZzZ4);

run{"Select None™):

run {"g-bit");

run{"Subtract Background...", "roclling=250");
fSeetTool {("rectangle™) ;

makeBectangle (3, 7, 1lll&, &05);

run{"Autc Crop”);

setiutoThreshold ("Default dark™);
S/run("Threshold...™);

setAutcThreshold ("0tsu dark™):
f/setThreshold (53, Z535);

setlption ("BlackBackground™, false):
run{"Convert to Mask"™);

run{"Gray Morphology™, "radius=5.5 type=circle operator=close™);

run {"Analyze Particles...™, "size=1-Infinity show=0utlines display summarize"?d

= This allows the exact same process to
be applied to multiple images.

= Process->Batch->Macro will apply a
macro to a directory of images.



Where to go from here...

= |mageJ documentation is online.

= Web searches will turn up many years worth of online discussions on
ImageJ features.

= A vast array of plugins and macros are available.
= And you can write your own!’

= For processing large batches of images version 1.51g of ImageJ is
available on the SCC using the fiji/l2015.12.22 module.

= Contact Research Computing Services for help. help@scc.bu.edu
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Additional Materials
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Image File Formats

= Raster
= TIFF, PNG, BMP, JPEG, GIF, JPEG200 (and many more!)
= |.e. files ending in .tif, .png, .bomp, .jpg, .gif, .jp2

= Vector

Portable Document Format - .pdf
PowerPoint - .ppt

Adobe lllustrator - .ai

Photoshop - .psd

PostScript - .ps

Encapsulated PostScript - .eps
Drawing and CAD packages
Scalable Vector Graphics - .svg

.

.
.
.
.
.
.
.
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Vector vs. Raster

= Vector images can be scaled to any size
or resolution.

= Typically produced when creating computer graphics
(plotting, drawing, diagrams, text, etc.)

= Example: TrueType fonts

= Raster images:

= Scaling up or down requires a mathematical
transform on the original image.

= Re-scaled raster images are not identical to the
original, and the original image may or not be
recoverable from a re-scaled version.

= Produced by physical image acquisition: cameras,

scanners, eftc.
BOSTON
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= 7x Magnification

/ \

er ice
| | ‘nts

lce Cream

R

| Bitmap

From: https://en.wikipedia.org/wiki/Vector_graphics




Vector Image Files

= Many packages create their own proprietary formats.

= Vector files are usually resolution independent.
= Thus, they can be easily printed at different resolutions.

= Line thickness may be an issue.

= Converting to raster image format should be done with care and only as a
last step when necessary.
= The transformation to a raster image is completely nonreversible.

= Use anti-aliasing if possible when doing the conversion.

BOSTON
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Vector Image Files — PostScript Example
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(o)

3!

PostScript code

0 setlinewidth

/Times—-Roman

findfont

306 427 moveto
240 330 lineto
323 332 lineto
306 427 lineto

12 scalefont setfont3pg 427 moveto

0.0 setgray

0.000 setgray

newpath

00
374
323
240
287
374
306
287
240
306

moveto

328
332
330
326
328
427
326
330
427

moveto
lineto
lineto
lineto
lineto
moveto
lineto
lineto

lineto

323 332 lineto
374 328 lineto
306 427 lineto
306 427 moveto
374 328 lineto
287 326 lineto
306 427 lineto
0 setlinewidth
stroke

showpage

= Vector images store image information as
specifications for a set of polygons.

= To display, the polygons are mathematically
scaled to the desired size and resolution and
then rendered (rasterized, i.e. converted to a
raster image).

~§~§~§~§~§~§§§§~§-§“‘~>




Color Image File: 24 Bit Full Color Pixel Values
(28x28x28=16.7 million possible colors)

R G B R G B R G B
0O 0 © 128 0 O 255 0 0
128 128 128 0 128 0 0 255 0
255 255 255 0 0 128 0 0 255
P3 24 bit 3x3 Pixel Web Equivalents (Hexadecimal RRGGBB)
33 PPM File
000000 800000 FF0000
255
0001280025500 808080 008000 00FFO00
128 128 1280128002550
25525525500128 00255 FFFFFF 000080 0000FF
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Color Image File: 8 Bit Color Map - aka Indexed

(256 possible colors)

BOSTON
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Colorname Index# R G B
Black 0 0 0 0
Red 1 255 0 0
Yellow 2 255 255 0
Green 3 0 255 0
Cyan 4 0 255 255
Blue 5 0 0 255
Magenta 6 255 0 255
Dk red 7 128 0 0
Dk green 8 0 128 0
Dk blue 9 0 0 128
Gray 250 128 128 128
White 255 255 255 255

o0 7|1
250, 8 | 3
255 9 |5

An 8-bit value per pixel becomes an index in the
256-element lookup table, the color map.



Additive vs. Subtractive Color

CMY additive color

RGB additive color K is added to save

colored ink

= Additive color

= Computer monitors, where different intensities of red, green, and blue combine in each monitor
pixel to be interpreted by the brain as a specific color. The background of the monitor is black.

= Subtractive color
= Printer inks absorb different wavelengths from white light.

= The background of the image is white (e.g. a sheet of paper)

= The primary ink colors are cyan, magenta, yellow, and black, abbreviated CMYK.



CMYK example

= Subtraction from white
= Cyan subtracts red
= Magenta subtracts green
= Yellow subtracts blue

= CMYK is used as this combo produces a wide
range of colors from available inks

= Why not red, yellow, and blue as primary
colors? They produce a narrower range of
colors than CMY in modern printing.

BOSTON
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From: http://www.printingforless.com/rgb-cmyk.html

RGB vs. CMYK Iy y

Visible
Color Gamut

+ RGB
2 Color Gamut

r'/ v
(2

vl i Pantone (PMS)
rgb colors cmyk colors ; _ Color Gamut

(what you see on screen)  (printing inks will do this)

Yy

rgb colors cmyk colors
(what you see on screen) (printing inks will do this)

CMYK
Color Gamut

* Pantone is a 7-color ink
system: CMYK+OGV

= CMYK colors cannot be represented in a 1:1 correspondence with RGB values. The
space of colors they represent (the “gamut”) do not perfectly overlap.

= Some colors in RGB cannot be represented in CMYK.
= Which means you can'’t print some monitor colors.
= Monitor RGB <= printer CMYK calibrations are needed!

= This usually isn’t noticeable in color photos but can be significant in plots
and graphics.
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One more representation: HSB

= HSB: Hue — Saturation — Brightness
=  Sometimes HSV - Value instead of Brightness

= Another encoding, also 24 bits
= Convertible back-and-forth with RGB

= Hue is an index into a color map that matches the
visual rainbow.

= Saturation is the amount of color vs. white
= Brightness is the scale from black to white.

Ssaujybug

= Used in a couple of places in ImageJ
= Often seen In software color selection tools
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