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Tutorial Outline

= Image Format Types = Measurements
= Vector Images = Area and dimensions
= Raster Images = Histograms
= Raster Image Quality = ROI and masking
= Color = Thresholding
= Digital vs. Print = Quantification of intensity
= RGB and CMYK = Macros
= Getting Started with ImageJ * Recording and running
= Opening and saving images * Writing your own

= Selections and cropping
= |mage Adjustments
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Image File Formats

= Raster
= TIFF, PNG, BMP, JPEG, GIF, JPEG200 (and many more!)
= |.e. files ending in .tif, .png, .bomp, .jpg, .gif, .jp2

= Vector

Portable Document Format - .pdf
PowerPoint - .ppt

Adobe lllustrator - .ai

Photoshop - .psd

PostScript - .ps

Encapsulated PostScript - .eps
Drawing and CAD packages
Scalable Vector Graphics - .svg

.
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Vector vs. Raster

= Vector images can be scaled to any size

or resolution.
= Typically produced when creating computer graphics
(plotting, drawing, diagrams, text, etc.)

= Example: TrueType fonts

= Raster images:

= Scaling up or down requires a mathematical
transform on the original image.

= Re-scaled raster images are not identical to the
original, and the original image may or not be
recoverable from a re-scaled version.

= Produced by physical image acquisition: cameras,
scanners, etc.
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Vector Image Files

= Many packages create their own proprietary formats.

= Vector files are usually resolution independent.
= Thus, they can be easily printed at different resolutions.

= Line thickness may be an issue.

= Converting to raster image format should be done with care and only as a
last step when necessary.
= The transformation to a raster image is completely nonreversible.

= Use anti-aliasing if possible when doing the conversion.
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Vector Image Files — PostScript Example
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PostScript code

0 setlinewidth

/Times—-Roman

findfont

306 427 moveto
240 330 lineto
323 332 lineto
306 427 lineto

12 scalefont setfont3pg 427 moveto

0.0 setgray

0.000 setgray

newpath

00
374
323
240
287
374
306
287
240
306

moveto

328
332
330
326
328
427
326
330
427

moveto
lineto
lineto
lineto
lineto
moveto
lineto
lineto

lineto

323 332 lineto
374 328 lineto
306 427 lineto
306 427 moveto
374 328 lineto
287 326 lineto
306 427 lineto
0 setlinewidth
stroke

showpage

= Vector images store image information as
specifications for a set of polygons.

= To display, the polygons are mathematically
scaled to the desired size and resolution and
then rendered (rasterized, i.e. converted to a
raster image).
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Raster Image Files

= Raster image files are composed of a grid of pixels.
= Each pixel contains color or intensity information

= File formats support many types of raster image
= 24 bit full color — RGB (8 bits per color) — png, tiff, rgb, bmp, jpg, jp2
32 bit full color with alpha — png, tiff, rgb, bmp, jpg, jp2
8 bit color map — gif, tiff, rgb
Bitmap (black and white only) — tiff, bmp.
Grayscale — can be 8,16, or 24-bit — png, tiff, bmp, jpg, jp2
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Bits
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# of bits per pixel Range of intensity

(N) levels
(0 > 2N-1)
8 0 - 255
10 0-1023
12 0 - 4095
16 0 - 65,535
24 0-16,777,215
3x8 0 - 255 per channel
4x8 0 - 255 per channel

Image Type

grayscale

grayscale
grayscale
grayscale
grayscale
RGB

RGB with alpha

Computer
Representation

(C types)
unsigned char (8 bits)

unsigned short (16 bits)
unsigned short (16 bits)
unsigned short (16 bits)
unsigned int (32 bits)
unsigned int (32 bits)
unsigned int (32 bits)

The number of bits determines the number of intensity levels that can be digitally

encoded.

For non-power-of-two bits per pixel the image is usually stored in the next higher-up pixel

format.

= Example: 10-bit image stored as a 16-bit TIFF. Only values 0-1023 would be used.



What sets the # of bits and pixels?

= The physical device capturing the image sets the number of pixels
= The electronics that convert light intensity to an electronic signal sets the number of bits.

232 | 172 234 | 255

i 209 | 119 198 | 222

187 | 155| 162 | 188

206 | 178 | 195 | 245

The image as Pixel (spatial) Charge levels are read out 8-bit digitization assigns the
projected onto resolution set when by a digitizer with a fixed values shown.
the CCD chip. chip is manufactured. number of bits per pixel.

Charge accumulates Charge levels over the

per pixel during maximum bit value are

exposure. saturated.
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Color Acquisition

= Colorin an image can be acquired in
many ways. Here's 2 out of many.

= An RGB CCD or CMOS chip has 4
sub-pixels per pixel of spatial
resolution that detect red, green, or
blue

= A filter wheel is used to select a range
of wavelengths, and multiple images
are taken with a monochromatic chip.
= RGB images use 3 separate acquisitions
= “‘R”“G” “B” bands are user-selectable.

= More than 3 bands can be used for a multi-
spectral image.
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Factors Involving Raster Image Quality

Resolution: the number of pixels in the image (width x height) \

DPI: Dots per Inch ¢ o
= A term for printing where dots of ink are physical printed to a page

PPI: Pixels per Inch is the digital equivalent
= The number of pixels in an inch (as on a monitor)

DPI and PPI are often used interchangeably <1952

<214 >

Number of available colors in the image format.

Anti-aliasing: Essentially a blurring operation that is done to smooth images and graphics
when they are re-sized.

Compression
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* 850 x 1134, RGB |

Compression and Image Quality

= Compression in image formats saves size on disk
= Compressed images take longer to open and save

= Lossless compression:

= PNG format, TIFF, JPEG2000, others
= Does not alter the image

= A ZIP file is a non-image example of lossless compression Size (bytes)

= Lossy compression: TIFF 2,891,854
= JPEG format, GIF, JPEG2000 (careful!), others
= Discards information from the image PNG 2,630,062
= Much smaller file sizes than lossless compression
= Greater the compression, lower the quality JPEG 220,517
= Not suitable for the storage of scientific images!! (77% quality)
JPEG 449,654

(95% qualiy)



JPEG Compression F F h

o

N JPEG Quiality: 95% 50% 15%
<t B
i
Original
Orig — JPEG:
Same B&C)

= The JPEG algorithm compresses an image by removing detail from the image before
performing a lossless compression

= High-frequency information is discarded
= Sharp transitions in contrast

ESEEESE = Changes in color hue



Color Image File: 24 Bit Full Color Pixel Values

(28x28x28=16.7 million possible colors)
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R G B R G B R G B
0 0 0 128 0 0 255 0 0

128 128 128 0 128 0 0 255 0

255 255 255 0 0 128 0 0 255

P3 24 bit 3x3 Pixel
33 PPM File
255

0001280025500
128 128 1280 128002550
25525525500 12800 255

Web Equivalents (Hexadecimal RRGGBB)
000000 800000 FF0000
808080 008000 00FFO00
FFFFFF 000080 0000FF




Color Image File: 8 Bit Color Map - aka Indexed

(256 possible colors)
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Colorname Index# R G B
Black 0 0 0 0
Red 1 255 0 0
Yellow 2 255 255 0
Green 3 0 255 0
Cyan 4 0 255 255
Blue 5 0 0 255
Magenta 6 255 0 255
Dk red 7 128 0 0
Dk green 8 0 128 0
Dk blue 9 0 0 128
Gray 250 128 128 128
White 255 255 255 255

o0 7|1
250, 8 | 3
255 9 |5

An 8-bit value per pixel becomes an index in the
256-element lookup table, the color map.



So Far...

v = Image Format Types = Measurements
v = Vector Images = Area and dimensions
v = Raster Images = Histograms
v = Raster Image Quality = ROI and masking
= Color = Thresholding
= Digital vs. Print = Quantification of intensity
= RGB and CMYK = Macros
= Getting Started with ImageJ " Recording and running
= Opening and saving images * Writing your own

= Selections and cropping
= |mage Adjustments

BOSTON
UNIVERSITY



Additive vs. Subtractive Color

CMY additive color

RGB additive color K is added to save

colored ink

= Additive color

= Computer monitors, where different intensities of red, green, and blue combine in each monitor
pixel to be interpreted by the brain as a specific color. The background of the monitor is black.

= Subtractive color
= Printer inks absorb different wavelengths from white light.

= The background of the image is white (e.g. a sheet of paper)

= The primary ink colors are cyan, magenta, yellow, and black, abbreviated CMYK.



CMYK example

= Subtraction from white
= Cyan subtracts red
= Magenta subtracts green
= Yellow subtracts blue

= CMYK is used as this combo produces a wide
range of colors from available inks

=  Why not red, yellow, and blue as primary

colors? They produce a narrower range of
colors than CMY in modern printing.
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From: http://www.printingforless.com/rgb-cmyk.html

) Visible
RGB vs. CMYK
£

" (' * RGB
- Color Gamut

Pantone (PMS)

rgb colors cmyk colors ‘ Color Gamut
(what you see on screen) (printing inks will do this) § 4 CMYK
”“::9 ,/
.\_ |
,4',"-,"
=
* Pantone is a 7-color ink

rgb colors cmyk colors

system: CMYK+OGV
(what you see on screen) (printing inks will do this)

= CMYK colors cannot be represented in a 1:1 correspondence with RGB values. The
space of colors they represent (the “gamut”) do not perfectly overlap.

= Some colors in RGB cannot be represented in CMYK.
= Which means you can'’t print some monitor colors.
= Monitor RGB <= printer CMYK calibrations are needed!

= This usually isn’t noticeable in color photos but can be significant in plots
and graphics.
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One more representation: HSB

= HSB: Hue — Saturation — Brightness
=  Sometimes HSV - Value instead of Brightness

= Another encoding, also 24 bits
= Convertible back-and-forth with RGB

= Hue is an index into a color map that matches the
visual rainbow.

= Saturation is the amount of color vs. white
= Brightness is the scale from black to white.

Ssaujybug

= Used in a couple of places in ImageJ
= Often seen In software color selection tools
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So Far...

v = Image Format Types = Measurements
v = Vector Images = Area and dimensions
v = Raster Images = Histograms
v = Raster Image Quality = ROI and masking
< = Color = Thresholding
v = Digital vs. Print = Quantification of intensity
v = RGB and CMYK = Macros
= Getting Started with ImageJ " Recording and running
= Opening and saving images * Writing your own

= Selections and cropping
= |mage Adjustments
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And now for the main event...ImageJ!

= Home page: hitps://imagej.nih.gov/ij/
= From Wikipedia:

ImageJ is a public domain, Java-based image processing program developed at the National

Institutes of Health. ImageJ was designed with an open architecture that provides extensibility
via Java plugins and recordable macros.

= Notable features:

= Written in Java and runs on many platforms: Windows, Linux, Mac OSX, and more

= Supports reading & writing a wide variety of image formats

= Many built-in image processing tools

= Can be programmed using a built-in macro system or scripts written in a variety of languages
* R, Python, Java, and more

= Your own custom code can be added to your ImageJ install as a plugin and used like any
other program feature!
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https://imagej.nih.gov/ij/

.
Fii

= Fiji Is Just ImageJd: http://fiji.sc/

= A version of ImageJ that is pre-packaged with a large number of plugins
and macros.

= More convenient to set up than ImageJ

= The plugins, macros, and additional tools are oriented towards analysis of cell and other
biological samples.

= |n this tutorial we'll use Fiji
= Recommended for most people in bio-related fields
= Also the terms Fiji and ImageJ will be used interchangeably for this tutorial.
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http://fiji.sc/

Starting the program

= Open up Imaged
= On the training terminals double click on the
shortcut:

RCS Tutorials = ImageJ - ImageJ shortcut

= A small tool and menu window will open:

BOSTON
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Fiji shortcut

ImageJ shortcut

(Fiji Is Just) Image! — O
E& Edit Image Process Analyze Plugins Window Help
5 Ol | o]~ 4] 7| A @[] ofswlur] 0] 4] &)

x g

laaciefe) -
‘:»:» \J:ugus_‘l

(Fiji 1s Just) Imaged 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];




B BU_Firec.png (75%) - m} x

12800075 pocels, RGS, 4 BMEB
e

Opening Images

\Iﬁ {Fiji Is Just) Imagel —_ 0 %

ﬂe Edit Image Process Analyze Plugins Window Help
5 O] x| o] << s3]\ Al & [ @] oofsufun] 0| 4] 8] |=
(Fiji Is Just) Imaged 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];

= Under the File Menu, choose Open, then
navigate to the tutorial images directory, and
open the file BU_Fitrec.png

= RCS Tutorials - ImageJ - Tutorial Images

= Drag n’ Drop onto the window will also open

Images. -
Ctrl- - (“control hyphen”) | Zoom out

Ctrl -= (“control equal®) | Zoom in
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Tools

(Fiji ls Just) Imagel — [ >
File Edit Image Process Analyze Plugins Window Help
E@,‘E‘@‘f’:‘i ii’f_ﬁ\‘ﬂ‘@\‘@?‘ ‘ EthStk?LUTT;?‘j"‘@q‘ ‘::::
(Fiji Is Just) ImageJ 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit];

= A bunch of tools are visible by default.

= Place the mouse cursor over a tool to see its name. The little red triangle

means a right-click will select a different tool option. Many can be double-
clicked to see a configure window.
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Magic Wand
TOOIS agie wvan Color picker
Zoom
(Fiji ls Just) Imagel — [ >
File Edit Image PFDEESS malyze lugins Wlndnw Help

ao

(Fiji Is Just) ImageJ E.D-EI rLAE1-“ 51n J:aw 1.6.0_ 64§ [64- blt]-

\ ; \ S_— )
Y _ Text Menus Paint tools
Selection Angle tool |
tools Scrolling
| = Go ahead and try them out!

= Ctrl-Z will undo changes.

Multi-point
and point = You can always close the image and re-
tool open it to start over.

= Or choose Revert (Ctrl-R) from the File
menu to re-open the image.



(Fiji Is Just) Imagel - O pt
g8 Edit Image Process Analyze Plugins Window Help

New Al @|F ofswur] o] 4| a] |

Saving Images

Open Next Ctrl+Shift+0

Open Samples FOTiff..
Open Recent H Gif...
. . . Import o Jpeg...
= File Menu - Save will default to saving your RS
i Close Ctri+W ge-..
output as a TIFF file. Close Al Cirl+Shift+w | 2P
Raw Data...
- - . Save Ctrl+S
= File Menu - Save As provides a wide range image Sequence..
of options Revert Cier | AVL-
BMP_..
Page Setp..
Print... Ctrl+P PGM._
Export FOFTS..
Quit e
Selection...
Fix Funny Filenames XY Coordinates. .
Make Screencast Results. .
Text...
Analyze. ..
MHD/MHA ...
MHD/MHA compressed ...
DF3 ...
Mrrd ...

ICO ...
BOSTON
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HPM ..




S

R BU_Fitrecjpg — 0O
451x448 pixels; RGB; 789K

Selections and Cropping Image

" suws N0 4 0
=

= Use the selection tools to select an area of the image (circular, rectangular, etc.)
= Hold the Shift key to do multiple areas.

= Choose the menu option Image - Crop
= The image will be cropped to the minimum bounding box on the selection.

BOSTON
UNIVERSITY



Histograms

| B E |_Fitrec

| g [ Histogram of BU_Fitrec - | pod [ Red Histogram of BU_Fitrec - a X
i 41 3 pixels; RGB; GBK

300x240 pixels, RGE; 281K 300x240 pixels;, RGE; 281K

] 255 0 255
Count: 24505 Min: 0 Count: 24505 Min: 0
Mean: 124,545 Max: 251 Mean: 147.672 Max: 255
( StdDev: 45 214 Mode: 159 (644) StdDev: 50.751 Mode: 183 (684)
, . : wvaluse=2272 - _ e 4 value=120
| L|st| an].rl Lngl Live RGEl Llstl Cnp].rl Lngl Live |RGEL|
count=5 count=5284
= Select an area. = Click the Live button and drag your

= Click Analyze->Histogram or press Ctrl-H selection around.
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57 (Fiji Is Just) Image o= O X | B U Firecine B i

Image
. File Edit [[EeEY Process Analyze Plugins Window Help ‘451x4478pixels;'RB; 789K
Adjustments  2ec 0 el g1 ]0] |> |

Show Info... Ctri+l | Window/Level...
Properties... Ctrl+Shift+P | Color Balance...
Color »  Threshold... Ctrl+Shift+T
. Stacks »  Color Threshold...
. The I mage 9 Adj ustments Hyperstacks )\ Size. ..
- ‘ .
menu has a number of options Crop Cteshaisx | CamvasSie..
. Duplicate..  Ctri+Shiftsp | Lin€ Width...
to change color levels, image I Coordinates..
size, apply thresholds, etc. Scale.. Cti+E | Auto Threshold
Transform » Auto Local Threshold
Zoom »  Bleach Correction
Overlay »  Auto Crop
Lookup Tables ,| Auto Crop (guess background color)
Anndtate ’; Scale to DPI
Drawing 4
Video Editing 4
Axes 3
Convert
Convolve
Threshold 4
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Brightness/Contrast

= Choose Image - Adjust = Bright/Contrast
= Or use the key combo: Ctrl-Shift-C

= Move the sliders or use the Set and Auto
buttons to change the display.

= The Apply button will change the pixel values in
the image.
= Save the image to make these changes permanent.

BOSTON
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: Auto 4 Reset

Minimum

Maximum

|

Brightness

|

Contrast

Set Apply

Ctrl-Shift-C

Open B/C control



(Fiji Is Just) Imagel = O X
File Edit Image Process Analyze Plugins Window
Help ELQTG‘@‘-{‘A g ”\‘A‘O\‘ﬂ‘m‘ Dwv|5ﬂ ImageJ) Website...

Pencil Tool ImageJ News. ..

Documentation...
Installation...

Mailing List...

Dev. Resources...
Plugins. ..

Macros...

= The Help menu has extensive documentation on every part of ImageJ/Fiji. Macro Functions...
= |If you are not sure how to do something, start here! Examples »

= The Documentation option has a number of tutorials that guide you through
a variety of typical tasks.

Update Imaged. ..

Refresh Menus

About Plugins r
About Imaged....

Report a Bug
Help on Menu ltem
Switch to Modern Mode

Update...

Upload Sample Image...
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= Figure width 2.25 or 4.75 inches.

DPI vs. PIX6|S = Line art (graphs, etc.) must have at least 300

DPI resolution.
= Grayscale and color images must have at

= Journals will typically request images in 300 least 300 DPI.
(or higher) DPI resolution with a specified = Up-sampling artwork (artificially increasing
image size in inches. file size or resolution) is not permitted
= Vector illustrations and diagrams (preferred):
= As an example, the journal Science has the = .PDF, .EPS, Al
following specifications in its instructions: —< = Raster illustrations and diagrams:
= http://www.sciencemag.org/authors/instructions- = TIFE

preparing-revised-manuscript

= Vector and raster combinations for
photographs or microscopy images:
= PDFor.EPS

= Raster photographs or microscopy images:
= TIFF

= Keep your original images in case they’re
ever requested.

BOSTON B—
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http://www.sciencemag.org/authors/instructions-preparing-revised-manuscript

DPI vs. Pixels Example

= Congratulations! Science wants to publish your article.
= You want to include a fluorescence microscopy image in your manuscript.
= The journal wants at least 300 DPI and a width of 4.75 inches.

= What should the pixel resolution should you use to meet the
requirements? (remember DPI < PPI)

= Minimum spec of 300 DPI: 300 dots per inch X 4.75 inches = 1,425 dots (pixels)
wide.

= QOverachiever spec of 600 DPI: 600 dots per inch X 4.75 inches = 2,850 dots (pixels)
wide.
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DPI vs. Pixels Example x

X Scale: l—i
= Using the 600 DPI target and 4.75 inch width. e |
Width (pixels). |2830
Height (pixels). |2850
= High res image: 4096x4096 pixels / interpolation: [None 7]
= Resize image to 2850x2850 pixels. Save in the TIFF file format. I Fil with background color
= Average when downsizing: does some averaging to reduce S
resizing artifacts. Recommended to select this. o ”evﬁw'nld:ﬁ
.. |scaled_image.png
= Interpolation: Select an algorithm. Bicubic will usually give the e
best results at the slowest speed. oK | Cancel |
= The image will now be able print at the correct width without
changes. Ctrl-E Open resize tool
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DPI vs. Pixels Example x

XScale: |-
= Using the 600 DPI target and 4.75 inch width. vecae |
Width (pixels): lﬁ
Height (pixels): [2850
= Low res image: 256x256 pixels " nterpolation: [Noms 7]
= Resize image to 2850x2850 pixel. Save in the TIFF file format. S
= Average when downsizing: Has no effect when scaling up. v ietage wher downsizing
= Interpolation: Careful! The requirements are for upscaling only pcreat_e ”e“i;“;‘:lizwimage_png
with no upsampling (interpolation). Choose None for this journal. e i
= The image will now be able print at the correct width without oK | Cancel |
changes.

Ctrl-E Open resize tool

BOSTON
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Upscaling & interpolation

= None: Copies pixels into neighboring spots.
= Will look “blocky” with large amounts of upscaling.

= Bilinear: Fits straight lines through 4 neighboring
pixels and interpolates

= Bicubic: Fits a 3" order polynomial to 16
neighboring pixels and interpolates

=  QOpen 5x5.tif and let’s try this out.
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5x5 8-hbit

25x25 8-bit
No interpolation

https://en.wikipedia.org/wiki/Bilinear_interpolation

Bilinear \/ Bicubic

Adds new points: upsampling!

25x25 8-bit 25x25 8-bit
bilinear bicubic




Plot of 5x5 - O >
4 T1x325.12 pixels (530x258); 8-hit; 132K

200
5¥5 pixels; 8-hit; Ok -

Gray Value

1001

v

s

0 o R I L
] 1 2 3 4
Distance (pixels)

Mare =

Live | ¥=2, Y(X)=202

List | Save. .

= Zoom into 5x5.tif with Ctrl-+

= With the box tool, select the middle row of pixels.

= Choose Analyze->Plot Profile or Ctrl-k to see a profile plot of the middle row.

= Click in the image to undo the selection (or Ctrl-Shift-A)

= Open the resize tool with Ctrl-E. Increase to 25x25 pixels, pick an interpolation method,

BOSTON add a box, and plot its profile.
UNIVERSITY



300 T T 1 T
Profiles for each resized image
q o0— 60— 0o o—6—606—0
250 - —
S o—6—0
@
“ o O O
200 uy/;,\\\\ —
‘a ® @
> \
2 Q Y R\
] \
€ 150 - 1o \, ]
E, / ‘*\ @
a3 //
& y
b
100 |- i
K D
”r' \'XI‘
& \\
& \® —O— bilinear
50 - \ ) —O—none | ]
2/ . ~©- bicubic
& MRS
\\m’ 1\
(NS \ /
0 fa fa o | A o o |
0 5 10 15 20 25

horizontal pixel

= The profile data was extracted for each resized image using the List button in the lower
left of the Plot window.

= |tis important to understand what image algorithms are doing mathematically to your
BOSTON : .
image before applying them!



¥ (Fiji s Just) Image

8-bit images

File Edit Image Process Analyze FPlugins Window Help

Bolc|o~4

+ty
++_

Nalae

|

.

‘ Dw‘Stk‘LUT‘;?‘j‘@q‘ ‘}}

*»=186, y=143, value=105

Open another image file, Citgo_Sign.tif
Hover your mouse over part of the image. The x-y /
location and pixel values for the RGB channels will

be displayed in the lower let of the main window.

This is a 8-bit image so the value range is 0-255

When displayed, every grayscale image has a
colormap as you're using an RGB display!

Display the colormap: Image-> Color - Display

[ Cge Sgnnt
| B750d 50 paady; E-piL 297)

[ Look-Up Table
326x188 pixels, RGB; 239K

LUT
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Direct 8-bit

Sepia LUT
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Choose some other LUTSs:

—

[ (Fiji Is Just) Image

ﬂ-:- Edit Image Process Analyze Plugins Wi
[ O|x|o| |4

— O *
ndow Relp

N |A] o] 2| esu]uf 0] 4]0

*=186, y=143, value=105

cool LUT

Green Blue Fire
LUT

Remember this just effects the
display, not the image on disk
which remains an 8-bit
grayscale image.



Color Images

= |mageJ supports two types of color images, RGB
and composite.

= RGB images are standard color images.

= E.g. pictures from your smartphone or a three-color CCD or
CMOS detector

= Composite images are sets of grayscale images
that are assigned colormaps and then combined
to form an RGB image.

RGB
image

BOSTON
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Stacks and Hyperstacks

= |maged handles 4 dimensional images using a stack.
= The 4t dimension can be time or wavelength channel.

= Example 1. A set of grayscale microscope images taken over several minutes (grayscale
video)

= Example 2: A set of grayscale images acquired with different wavelength filters and a filter
wheel.

= Example 3: An RGB image
= A hyperstack adds a 5™ dimension

= Example 1: A set of grayscale images acquired with different wavelength filters with multiple
time steps per wavelength (multispectral video).

= Example 2: A set of RGB images acquired over time (color video)

BOSTON
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RGB images

= QOpen the image tetraspeck.tif. These are ThermoFisher
fluorescent microspheres.

= Convert this from an RGB image to a 3-channel stack:
= |mage->Colors—>Split Channels
= |mage->Stacks—>Images to Stack

= The scrollbar switches between slices in the stack.

= Press Ctrl-Shift-C to open the B&C control. Each
slice gets the same B&C setting.

= Hold the Shift key when moving between slices —
this will do the Auto B&C command for each slice.

BOSTON
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Merge Channels >

C1(red) |C1-Composite -

Back to RGB cocrom [eroomron ]

C3 (blue) |C3-Composite =
C4 (gray) |*Mone* -

Ch (cyan): IW'
o _Convert the stack back to a set of AP
I m ag eS : C7 (yellow) |*Mone* - O X

= |mage-> Stacks-> Stack to Images - creamposte
= Click on each image and choose the

matching LUT (Red for the red image,
etc.)

= Re-create the RGB image:
= |mages->Color->Merge Channels
= Check Keep source images

= The RGB image will open alongside the
other 3.

BOSTON
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4

4

1

I~ Ignore source LUTs

LOK | cancel




i Rat _Hippocampal_Neuron.tif — [
1/5;81.92x81.92 um (51 2X51 2) 16-bit; 2. 5MB 7

Composite Image

[i}" Channels
[Composite ~]
= Open Rat_Hippocampal Neuron.tif b e
- - v Channel 2
= This is a Fiji sample image v Channel 3
= This is a 4-channel fluorescent image with a white ;2::::::;
light image. ;
= The per-channel LUT information is stored by =

ImageJ in the TIFF file header.
= Choose Image—->Color->Channels Tool

= Choose Composite and try the options.

= Click More — try creating an RGB from your
composite.

= Now choose Color, then click More.
= Here you can change the LUT per channel

BOSTON :
Ctrl-Shift-Z | Open channels tool




So Far...

v = Image Format Types = Measurements
v = Vector Images = Area and dimensions
v = Raster Images v = Histograms
v = Raster Image Quality = ROI and masking

< = Color = Thresholding
v = Digital vs. Print = Quantification of intensity
v = RGB and CMYK = Macros

v = Getting Started with ImageJ * Recording and running
v = Opening and saving images * Writing your own

v = Selections and cropping
v = Image Adjustments
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Macros

= |ImageJ macros can be saved, edited, assigned to keys, and shared
amongst friends.

= The macro language is straightforward and supports all the built-in ImageJ
commands

= This gives users the ability to create re-usable image processing
programs without having to learn a language like R, Python, or Java.

= Choose Plugins>Macro->Record

= The window that opens will now record your commands.
= Leave it open!

BOSTON
UNIVERSITY



_Il.A T

Measuring Images

= Open banana.png

= Click the straight line tool, then
draw a line between some of
the centimeter marks on the
ruler.

= Choose Analyze->Set Scale.

= Set the Known distance to the cm’s

[U7 Set Scale *

Distance in pixels: |ElEEekE

known distance: |1.DD
yOU Choose' Pixel aspect ratio: |1.D
= Set the Unit of Length to cm Unitoftength: [om
= Press Ctrl-Shift-A to remove the I o e Scale |
Global
line.

Scale: 50.8334 pixelsicm

BOSTON OK | Dancell Helpl
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Measurements cont’d

= This is an RGB image, choose
Image->Type->8-bit to convert it.

= The background is uneven.
Process—> Subtract Background and enter

250 to do a rolling ball subtraction. \

= Ctrl-Shift-C to adjust B&C if you like.

= Draw a rectangle around the banana and
choose Image—->Crop

BOSTON
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Subtract Background... *

Ralling ball radius: E pixels

[ Light background

| Create background (don't subtract)
[~ Sliding paraboloid

[ Disable smoothing

[ Preview

Ok | Canu::el| Help|




Measurements cont’d

Thresholding: Pick a pixel value V.

= Pixels >=V - assign max value
= Pixels <V - assign zero value.

= Using a statistical threshold is much more
reproducible than selecting thresholds by

Red indicates value below the threshold.

hand.
= Image—->Adjust->Threshold Click Dark
background. Select a few, see what L
happens. U7 %
= Choose Otsu and click Apply. Close the j . Jj
Threshold window. TR | T

I Dark background | Stack histogram

Auto | Apply | Reset | Set |
UNIVERSITY




Parameters >

This plugin perfarms morphology operators on graylevel images

M eaS u re m e n tS CO nt, d Radius of the structure element (pixels): [5.5

/ Type of structure element | circle v|

[ Show mask

= Fill in the holes in the banana with
Process->Morphology-> Gray
Morphology

=  Apply a close with a radius of 5.5 pixels. s )58 s

Operator clr:-se -

OK | Cancel|

= The close applies a dilation followed by
an erosion.

= For details on erosion and dilation see:
http://micro.magnet.fsu.edu/primer/java/digitalim
aging/processing/erosiondilation/

BOSTON
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http://micro.magnet.fsu.edu/primer/java/digitalimaging/processing/erosiondilation/

= Now use Analyze->Analyze
Particles

= Under Size enter 1

= Check Display Results and
Summarize

= Choose Outlines under Show.

= More measurements can be
set: Analyze—> Set
Measurements

BOSTON
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Analyze Particles

Size (cm*2):

[ Pixel units

Circularity: |EI.EIEI—1.EIEI

show: [Outlines R

v Display results
[ Clear results
[+ Summarize

v Addto Manager

[ Exclude on edges
[ Include holes

[ Record stans

[ In situ Show

0K | Cancel| Help|

File Edr Fort Resuls

e Et Fom

- es iMean’iMn e (e | iRswniOen: |
1 L - 0 v b e ] e -} ke S0 4 |

avsd 3 255 21045 200

«| Sk [Count [Tota Area [AverageSan [NAres wean |inmen | |
pananaprg 1 §2 547 2847 31 697 2

g
,‘
/ YII
- // ,"'I
{
//” l’
7 — : J
R /
X
#
b7
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Macro window

= |t should look something like this:

Recorder — O

Record: |Macro »| Mame: |Macro.ijm Create| ﬂ

>

= Close all of your windows except the
macro recorder.

= Click the Create button. The full macro
editor will open.

= Close the macro recorder.
= Click the Run button. What happens?

= The macro editor can save your macro,
and you can run it any time.

BOSTON
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v

open ("Ci\\Users\\bgregor\\Documentsy\RC5 Tutorials‘\\Introc to Imaged\\Images
“whanana.png™) s

gelectWindow ({"banana.png™) ;

setTocl("line™);

makeline (31, ©¢d4, €62, &€80);

run{"Set Scale...”, "known=1Z unit=cm™);
makeline (615, 228, €15, 22&);

makeline (615, 224, €15, ZzZ4);

run{"Select None™):

run {"g-bit");

run{"Subtract Background...", "roclling=250");
fSeetTool {("rectangle™) ;

makeBectangle (3, 7, 1lll&, &05);

run{"Autc Crop”);

setiutoThreshold ("Default dark™);
S/run("Threshold...™);

setAutcThreshold ("0tsu dark™):
f/setThreshold (53, Z535);

setlption ("BlackBackground™, false):
run{"Convert to Mask"™);

run{"Gray Morphology™, "radius=5.5 type=circle operator=close™);

run {"Analyze Particles...™, "size=1-Infinity show=0utlines display summarize"?d

= This allows the exact same process to
be applied to multiple images.

= Process->Batch->Macro will apply a
macro to a directory of images.



Sample fluorescent image measurement L

Minimum

| 2048x2048 pixels; RGB; 16MB

= Openimage TfnR-A555-Rab11-A647-341- |
01.tif
= Provided by John Chamberland of BU
= The red is transferrin receptor, a carrier protein
= The greenis Rabll, an enzyme

= |maged to investigate when these molecules are |
colocalized.

Maximum

]
]

Brightness

Contrast

Reset

Apply

= Adjust the B&C as you like (don’t press Apply)

= We will measure the intensity, location, and size of
the red fluorescent transferrin receptors.
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Red Channel

= Strategy:
= Remove the background (out of plane light)

= Segment the red channel image into separate blobs for
measurements.

= Make the measurements on the original red channel image.
= Save the measurements to a file.

= Split the RGB image into separate channels:
Image->Color->Split Channels

= Close the green & blue channels

= Click Image->Duplicate to make a copy in a new
window.

BOSTON
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Background |

2048x2048 pixels; 8-hit, 4MB

= Adjust B&C again.
= Click Process-> Subtract Background

= Apply a 12 pixel radius rolling ball subtraction

Subtract Background... >

Raolling ball radius: m pixels

[ Light background

[ Create background (dont subtract)
[ Sliding paraboloid

| Disable smoothing

[ Preview

] | Cann:el| Help|

= Note that there are many other ways to do a
background subtraction...
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Threshold =

Thresholding \

5.20 %
eI 2| 2
B D 2

Rab11-4647-341-01-1.tif (red)-1 (33.3%) — O x
j els; 8-hit (inverting LUT); 4MB

= Now apply a threshold to select R S e e

e

oo

|otsu ~| |Red

. . .Auto| Apply| Reset|ﬂ ' ﬂ ..‘:')‘f;'i;..:‘," ‘ »?’ .
brighter regions LRI
1 1 ‘ o ‘:',’; :;::r r‘."-’?f ‘ 1-. Fe "
= Click Image->Adjust-> Threshold L - S Al
, LV BT e Ay S L
= Which threshold to use? oo R O LR
o omte g U R a e
I 4 .. '-_l.-"a ‘v ), Lt
= Try afew! ST S
. v Yy e
SR et T ,
Apply. SEOIEON P VT
: r . L e "y et

BOSTON
UNIVERSITY




Analyze Particles >

Size (pixel*2). |4-2500
C re ate R O I S Circularity: |EI.EII:I—1.EIE|

Show:  |Nothing |
* ROI: “Region of Interest’ e o
= |mageJ can handle many ROIs at e
once using the ROl Manager tool. ok | [Gareet | [1es |

= Click Analyze->Analyze Patrticles.
= Set the size to 4-2500

RO.. — O X
= Set Show to None 0010005 1] s
: 0003-0001 il
= Uncheck evel‘ythlng but Add to 0004-0004 Delete
0005-0004 Rename...
Manager 0006-0004 Measure
_ 0007-0002 ————
" CIICk the OK bUttOn. gggsgggj Properties...
i 0010-0002 Flatten [F]
= The ROI manager will open. ovt1 000 ore -
0013.0004 W Show All
0014-0006 ~ | Labels




Measurements

= Click the original red channel image.

= |n the ROl manager, click in the list of
ROIs and press Ctrl-A to select them
all.

= Click the Add button.

= Uncheck the Labels option.

= The ROIs will be highlighted in the
original image.

= Click Analyze-> Set Measurements,

choose some measurements to make.

BOSTON
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ROl Manager — O ot
0001-0003 ; Add [t
0002-0002 1=
0003-0001 Update
0004-0004 Delete
0005-0004
Q006-0004 Rename...
0007-0002

Measure
0008-0004
0009-0007 Deselect
0010-0002 .
0011.0005 Properties...
00120015 Flatten [F]
0013-0004
0014-0006 LTS
0015-0002 W Show Al
ﬂﬂ'lﬁ-ﬂﬂng remeeemeeem——— .
0017-0005 - iLabels:

Set Measurements *

W Area [idean gray valug,

[~ Standard deviation |~ Modal gray value

[~ Min & max grayvalue [ Centroid

[+ Center of mass I~ Perimeter

[ Bounding rectangle [ Fitellipse

[~ Shape descriptors | Ferets diameter

I¥ Integrated density [ Median

[ Skewness I Kurtosis

[~ Area fraction I~ Stack position

[~ Limitto threshold [ Display label

[ InvertY coordinates [ Scientific notation

[~ Addto overlay [~ MaM empty cells

Redirectto: |None |

Decimal places (0-9): |2

0K | Cancel| Help|




Results — Oa >
File Edit Font Results
y [area [RM M IntDe RawintDen -]
Measurements cont'd s mmmzm e
2 a 1304.899 2232 321 321
3 ] 1308.306 1.079 216 2186
4 a8 1328.609 3382 4837 4837
. o] a7 1423799 2819 3283 3283
= |In the ROI manager, click the 6 50 1444501 343 o558 58
7 13 1495.603 1.168 281 281
Measure button. S oo D Sl -
4 »

= This will measure all ROIs | o

PR W T
oo 158,75 O @ o
:

AR AP Al
Borves

separately.

= Click Analyze->Measure to measure
all the ROIls as a single area

= Measurements will be displayed in a
new window.

= The measurements can be saved or
copied using the File and Edit
menus.
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| £ Imagel Updater — O >
Addi Pluql
g g Mame | Status/Action Update Site
plugins/BAR_.jar Instal it BAR
| Manage update sites Apply changes | | Advanced mode | | Cancel |

Click Help>Updates

= Click the Manage Update Sites button

= Click a site or too, then click the Close button.
= New plugins can now be installed.

BOSTON
UNIVERSITY



Where to go from here...

= |mageJ documentation is online.

= Web searches will turn up many years worth of online discussions on
ImageJ features.

= A vast array of plugins and macros are available.
= And you can write your own!’

= For processing large batches of images version 1.51g of ImageJ is
available on the SCC using the fiji/l2015.12.22 module.

= Contact Research Computing Services for help. help@scc.bu.edu
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