
Turtle EDA Processing Protocol 
 

Helpful Shortcuts 
 
Zoom out: Ctrl + H  

Autoscale: Ctrl + Y 

Connect endpoints: Ctrl + shift + 1 

Toggle view Selection Palette: Ctrl + shift + = 
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Setup and Preprocessing 
 

1. Find a new participant file to work on 

a. Open the “Turtle EDA Processing Tracker” on Google Sheets. If it has not been shared with you, reach 

out to a project leader for access.  

b. In the tracker, navigate to the “PROCESSING” tab at the bottom of the screen. Find a file to edit that has 

not been completed yet.  

i. As an example, let’s say we chose participant ID 999 at timepoint T1.  

2. Create a new folder to house your participant’s data 

a. You won’t do anything with this now, but you will need this folder to save your processed files here. 

b. First, check for a folder here with your participant’s ID and time point. 

i. You can click on the hyperlink or navigate to the file (Dropbox\Research_Turtle\EDA 

Processing\DATA PROCESSING) 

c. If the folder does not exist, create a new folder and name it (e.g., 999_All).  

i. Open the folder and create another folder for your file’s timepoint (e.g., 999_T1) 

3. Load your participant’s EDA Data into Acqknowledge 

a. To open a new (not yet processed) EDA file, navigate to the participant files 

i. You can click on the hyperlink or navigate to the file (Dropbox\Research_Turtle\EDA 

Processing\All files - use for processing) 

ii. Find your file (e.g., 999_T1.acq) and double click to open in Acqknowledge 

1. Note. In most cases, there should be three files for each person (T1 = Time1, T2 = Time2, 

T3 = Time 3). Make sure you select the correct time point 

b. A load screen will pop up with a dialogue box. Click on “Analyze Only.”  

  

https://docs.google.com/spreadsheets/d/1_-1Ey1tWve4-1WqS5jtf8Ko9Mr-rMD-GiTP1mqZD_d4/edit?usp=sharing
file:///C:/Users/trupo/Dropbox/Research_Turtle/EDA%20Processing/DATA%20PROCESSING
file:///C:/Users/trupo/Dropbox/Research_Turtle/EDA%20Processing/All%20files%20-%20use%20for%20processing
file:///C:/Users/trupo/Dropbox/Research_Turtle/EDA%20Processing/All%20files%20-%20use%20for%20processing
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c. Now your data file should pop up and look something like the image below. You should make the 

program full screen if it isn’t already. 

 
4. Open necessary tools before processing 

a. Click on   and choose Show All. You can close all of the windows that pop up except the one called 

Selection (shown below).  

 

5. Auto-scale waveforms to help identify which channel is EDA data, and which is just noise 

a. Click on this to autoscale   or right click on the data and select Autoscale Waveforms. 

b. After you auto scale the waveform, for most of the participants, there should be two channels with 

“EDA” in the name (10 or 13). One of them is very fuzzy (green wave) and the other is cleaner (red 

wave). We only need the channel that is cleaner for mother’s EDA data (usually it is channel 10 – if it is 

NOT channel 10, please note this in the participant log) 

 

c. Close the channels that you are not working on (e.g., PPG, Analog input, the fuzzy EDA channel).  

i. To close those channels, hold down the Alt key and click on the channel number on the top-left 

side. Successfully closed channels will be crossed out.  

 

Full screen 
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ii. After you close all other channels, you should only be viewing the EDA data and your screen 

should look like this. In this example, channel 10 is the one that we are going to work on. 

 

6. Check that “Duplicate Waveform” is NOT selected 

a. Click on OR go to Display Preference tab --> Waveforms 

b. Make sure that the box next to “Duplicate before transformations” is NOT checked and hit OK. 

 

7. Run filters to smooth data and remove noise 
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a. Select “Low Pass” from the shortcuts bar or go to Transform > Digital Filters > FIR > Low pass filter. 

 
 

b. In the low pass filter window, select [Fixed at] and change it to 1 Hz. Then hit OK. 

 

c. Note: If the data still looks too messy or fuzzy after running the low pass filter, it is possible a high pass 

filter is needed. Make a note of it and be sure to mark the file as Second Look in the tracker. 

 

8. Down-sample the channel 

a. Select “Resample Waveform” from the shortcuts bar (or go to Transform > Resample Waveform). 

 
b. Change “New Waveform Sample Rate” to 125 samples/second and hit OK. 
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Timing Flags and Focus Areas 
 

1. Now, it’s time to insert timing flags and focus areas into the file so that we can analyze each task separately. 

a. The Selection Palette should already be displayed. You will use this to enter in start and end times of 

task/Focus Area 

 

Note: If you don’t see this window go to Display > Show > Selection Palette or use the shortcut 

Ctrl + shift + =. 

b. In the Turtle EDA Tracking Sheet, navigate to the Timestamp tab that corresponds to the same time 

point (i.e., T1, T2, T3) as your file. It is VERY important that you use the right participant and time 

point for the timestamps. You may want to bold (Ctrl B) the row to help you keep track of the right one. 

Just make sure to un-bold when you’re done with that participant. 

2. Start with the first task (Video 1) and repeat this step for each task. This step is very important so move slowly 

and pay careful attention to what you are doing. 

a. Enter the start and end time of the task into the Selection box and hit ENTER 

Note: It doesn’t matter if you put start/end time in Left or Right box. The smaller digit will 

automatically be placed in the Left Box, and the larger digit will automatically be placed in the 

Right Box. You may find it easier to enter the larger number first.  

b. You should now see a section of data outlined in blue 

 

c. Click on the dropdown menu in the Selection Palette and select “Create Focus Area…” Alternatively, you 

can right click on the blue region > select Create Focus Area. Label the selected region with the name of 

the task (e.g., Video1, Clown, Video2, etc.) and hit OK. 
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Note: If you create an incorrect focus area and need to delete it, choose the Focus Area in the “Focus 

on” menu and click on the “-“ button to the right. A warning will pop up and you need to confirm the 

deletion. You can also use this menu to select any of the focus areas you have previously made. 

  

 

d. Create focus areas for all tasks. 

 

 

3. Now, you need to add start and stop flags 

for the beginning and end of the focus 

area. 

a. Select the first task using the 

‘Focus on’ menu: 

 

c. Then, click  and select 

Event Palette. When the event 

palette appears, choose “Mark 

Selection” under the “Actions” 

menu (see red arrow in image to 

the right)  
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d. This will create 2 new rows in the Event list that 

are labeled “Selection.” The value under 

Location should correspond to the start and stop 

times for the focus areas that you selected in the 

‘Focus On’ menu. 

 

 

 

 

 

e. Click on the first Selection (Selection Begin) and enter “[task name] Start” (e.g., Video1 Start) where it 

says Label. 

 

f. Click on the other Selection (Selection End) and enter “[task name] Stop” (e.g., Video1 Stop) where it 

says Label. 

g. Repeat this step until you have created start and stop flags for all tasks. 

i. Double check that you have flags for all tasks AND that start flags are Selection Begin and stop 

flags are Selection End. Make sure that the “Location” times match what is in the Timestamps 

tab on the EDA Tracking Sheet! 
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STOP 

9. You can close the Event Palette. You should also see focus areas for all tasks, as shown below. When you have 

finished adding focus areas and flags for all tasks, you can close the Event Palette and the Selection Palette. 

Update the EDA Trackinhg Sheet (PROCESSING tab) by entering a ‘1’ under the column that says “Created focus 

areas and flags.” 

 

10. Now that you have created the focus areas, SAVE THE .ACQ FILE BEFORE MAKING MORE EDITS.  

a. Go to File > Save As and navigate to the folder you created earlier: Dropbox > Research_Turtle > EDA 

Processing > DATA PROCESSING > ID_All > ID_TX (green part is specific to your file). Save the file as 

ID_TX_FocusAreas_yourinitials. For example: 092_T1_FocusAreas_TP. 

b. DO NOT save the file again until you have finished making edits (you will save it with a different name, 

described later in the manual). 

 

IF YOU ARE ONLY CREATING FOCUS AREAS, STOP HERE 
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11. After creating focus areas, zoom out and identify usable/unusable blocks before editing 

a. For the example below, you would identify Clown, Video 2, Kids, Introduction as unusable and NOT edit 

because more than 20% of data would need to be edited. Uneditable blocks should be marked 999 in 

the tracker.

 

 

12. We want to delete any data before or after our focus areas, because this data should not be analyzed. 

a. Use the Selection tool  to select the entire area before Video 1 (get as close as you can without 

getting the marker in the selection). 

 

b. Once it is selected, go to Edit → Clear All (DO NOT SELECT Edit → Clear, it will shift all your focus areas!). 

The region you selected should now be deleted. Make sure you don’t accidently delete any part of the 

focus areas or flags.  

 

c. Do the same thing for the entire area after Video 3. 

d. You should also delete any focus areas that you marked as uneditable. Areas in between tasks should 

be treated the same as focus areas – edit them if they are editable, delete them if they are uneditable. 

e. Now you should only see the usable focus areas and the space between tasks (no data before the first 

task or after the last task).  
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Removing Artifacts 
Now, you want to go into the sections that have artifacts and remove them. (If there are no artifacts, you can skip to 

“Marking Skin Conductance Responses”) Artifacts may look like a sudden steep dip or spike. See below for examples: 

 

 

1. Turn ON duplicate channel by going to Gear icon > Waveforms. Check the box next to “Duplicate before 

transformations” and hit OK. 

General note: You should have this option selected when you first use “Connect Endpoints”, but then turn off after the 

first edit to prevent creating a new channel for every single edit. If you are not editing, leave the “Duplicate before 

transformations” unchecked. 

  

2. Using the magnifier  (the zoom tool), draw a square around the area that has the artifacts. This will zoom 

into the area that you select. To more precisely scale the wave, click on the x axis number and change the scale 

to 20 seconds (5 blocks of 4 seconds) 
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3. Highlight section you want to remove using . Like IBI Editing, you want to edit as little as possible and 

only remove data that truly appears to be an artifact. If you are not sure about the artifacts, leave them as they 

are, make a note of them, and check with us. You can also send a screenshot of the artifact in the EDA 

Processing slack channel for guidance. 

 

4. Select “Connect Endpoints” on the shortcut bar, (or go to Transform > Math Functions > Connect Endpoints, or 

use the shortcut Ctrl + shift + 1.) 

 

 

 

                               

a. After you’ve Connect Endpoints the first time, the program will create a new, duplicated channel. We 

want to avoid creating a new channel each time you make an edit so go back and UNCHECK “Duplicate 

before transformations” after your first edit. You can close the old channel (the one without the edit). It 

is VERY IMPORTANT to know what the most recent channel is so that we can generate measurements 

from it later.  

b. Repeat Connecting Endpoints until all artifacts are removed from the file. 

5. For each task, record in the tracker whether you edited the data (0 = No edits, 1 = Edited). 

a. For files where you did edit, we want to keep a record of how much of the file was edited. We do this by 

making a note of roughly how much time was edited. You can get the length of time for a selected area 

by using the Delta T tool in the measurement bar. 

b. Click the black triangular dropdown arrow shown in the image below and select the preset called “Turtle 

EDA.”  

Before 

connecting 

endpoints 

After 

connecting 

endpoints 
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c. On the second row all the way to the right of the measurement bar, you should now see Delta T 
 

d. Open up the original channel you were using 

before any edits were made (most likely channel 

10 but it depends on your file). Select the section 

that you edited, and the value in the Delta T box 

will tell you how many seconds you edited (26.31 

seconds in this example). Add up the time for all 

the edits you made for each task (you can 

estimate to the nearest second) and enter it in 

the EDA Tracking Sheet. 

 

Note that you can do this as you are making edits 

instead if you find that to be easier. 

 

 

 

 

 

6. Note that you should also remove artifacts that are in between focus areas, because they could affect the 

output. You don’t need to make note of these edits in the tracker but it is important that ALL artifacts in the file 

are removed. 

7. Zoom out to double check that the edited channel looks clean now and make sure the EDA Processing Tracker is 

updated. 

  

Edited channel 

Unedited channel 
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Marking skin conductance responses 
 

1. Select Preferences in the shortcut bar or go to Analysis > Electrodermal activity > Preferences 

a. Make sure the settings match what is shown below and hit OK.  

 

  

 

2. Convert tonic EDA to phasic EDA 

a. Make sure the channel where you have done all the edits is the active channel. For example, if the most 

recent / most edited channel is channel 6, the channel bar should look something like this (channel 6 

highlighted in blue to show that it is selected) 

 

b. Select Locate SCRs in the shortcut bar. For Tonic EDA channel select the active channel (the one where 

you have made the edits) and choose “Construct new.” Hit OK. 

 

 

3. You should now see something similar to the examples below. Water droplets represent the peak of the 

response. The first parenthesis is when the response starts –when the slope of the line in the phasic channel 

changes and goes over 0.03. 
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Exporting data 
 

Now that the data is ready, we can prepare it for exporting. 

1. Click the black triangular dropdown arrow shown in the image below and select the preset called “Turtle EDA.” 

Even if you have already done this, do it again! 

                           

 

2. Make sure the channel with the water droplets is the one that is selected. If not, click the number that 

corresponds to the correct (i.e., the most recent) channel in this bar to select it. 

 

3. Now we are ready to extract the data. In the shortcut bar, click Find Cycle or navigate to Analysis > Find cycle. 

We will now generate the Excel file. Follow the steps below very carefully to ensure that the data is exported 

with the correct settings.  
 

4. We will locate cycles from events. 

a. Make sure the settings on the first tab (Cycles/Peaks) match what is seen below. 

i. Choose locate cycles from events 

ii. Start event is Selections > Selection Begin located on Anywhere 

iii. End event is Selections > Selection End located on Anywhere 
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b. Make sure the settings on the second tab (Selection) match what is shown below and click the button at 

the bottom that says Move Cursor to Origin. 

 

c. Make sure the settings on the third tab (Output) match what is shown below. You will only need to 

change the “Measurements” tab. 

i. Check the box next to “Save measurements into Excel spreadsheet file” 

ii. Click the dot that says “Ask for spreadsheet filename and location” 

iii. Check the box next to “Open spreadsheet after final cycle is found” 

 

d. Click the button that says “Apply Measurement Preset” (see red arrow in image above) and select 

“Turtle EDA”  

5. In the menu at the bottom on the Find Cycle window, click Find All Cycles 

  

a. This will prompt you to save the file. 

i. Navigate to the folder for your participant and timepoint that you created at the beginning in 

Dropbox > Research_Turtle > EDA Processing > DATA PROCESSING > ID_All > ID_TX (green part is 

specific to your file) 

ii. Change the filename to ID_TX_EventOutput_Initials (see below for an example with participant 

92 T1) and click Save. 
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b. This will open an Excel file that looks similar to the one below 

 

i. We need to add a column to label each task. You should do this manually by typing “Task” into 

Row 1, and then typing the corresponding task name for each row. The tasks will appear in the 

order that they appeared in the file. Create the labels based on the Focus Areas that are in your 

file 

 

ii. We need to double check that the data was outputted correctly. Pick one task and count the 

number of water droplets that show up in Acqknowledge for that task. Then, check the column 

labeled “Evt_count” and make sure the number is the same. In the example below, Video1 has 

10 water droplets, so would make sure that “Evt_count” also says 10 for that task. If the 

numbers do not match, make a note of it and post in the Slack channel. 
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iii. If everything looks good, you can save the file and close it. The following warning may appear 

when you try to save the file. Just click OK and save the file with the same name and location (It 

just wants you to save it as .xlsx instead of .xls) 

 

c. Go to the Exported events column in the EDA Tracking Sheet and change the value to 1. Add any General 

Notes about the file, and change the color of the row (Green for completed, yellow for second look) 

 

d. The last step is to save the edited .acq file. Go to File > Save As and navigate to the same folder where 

you saved the Excel file: Dropbox > Research_Turtle > EDA Processing > DATA PROCESSING > ID_All > 

ID_TX (green part is specific to your file). Save the file as ID_TX_EDITED_yourinitials. For example: 

092_T1_EDITED_TP. 
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Additional Resources 

Changing “Selection” palate from default minutes to seconds 
1. Click on the arrow on your Selection palate → Time Units → Seconds. You should only have to do this if your 

software was recently installed with the presets. 

 

 

Instructions to output epoch data by Focus Area  
 

1. First, we will locate cycles from fixed time intervals. 

a. Make sure the settings on the first tab (Cycles/Peaks) match what is seen below. 

i. Choose fixed time intervals 

ii. Starting time should be manually specified as 0 seconds 

iii. Interval width should be set to 15 seconds 

 

b. Make sure the settings on the second tab (Selection) match what is shown below 

i. Left edge set to Previous interval + 0 seconds 
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ii. Click Move cursor to origin to make sure the analysis is starting in the right place. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

c. Make sure the settings on the third tab (Output) match what is shown below. You will only need to 

change the “Measurements” tab. 

i. Check the box next to “Save measurements into Excel spreadsheet file” 

ii. Click the dot that says “Ask for spreadsheet after final cycle is found” 

iii. Check the box next to “Open spreadsheet after final cycle is found” 
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d. Click the button that says “Apply Measurement Preset” (see red arrow in image above) and select 

“Turtle EDA”  

e. In the menu at the bottom on the Find Cycle window, click Find All in Focus Areas and choose Single 

spreadsheet 

 

f. This will prompt you to save the file. 

i. Navigate to the folder for your participant and time that you created at the beginning in 

Dropbox > Research_Turtle > EDA Processing > DATA PROCESSING > ID_All > ID_TX. 

ii. Change the filename to ID_TX_FocusAreas (see below for an example with participant 92 T1) 

and click Save. 

 

iii. All the measurements that 

you have selected for the 

channel will now be in the 

excel file, separated by task. It 

should look something like 

the image to the right 

iv. Look through to make sure all 

tasks were exported correctly 

and then close the Excel file. 
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Creating the Turtle EDA Preset 
We can select the measurements for the channel that we are working on in the red boxes on top. The type 

and order of the measurements that you select are very important and they should be all based on the active 

selected channel (SC).  

You need to select these measurements in the following order from left to right, first and second row: 

1. Min 

2. Max 

3. Mean 

4. Stddev 

5. Evt_count > EDA > skin conductance response  

6. Evt_amplitude (Amplitude at first event only) > EDA > skin conductance response 

7. Evt_amplitude (Mean amplitude from all events) > EDA > skin conductance response 

8. Evt_amplitude (Maximum amplitude from all events) > EDA > skin conductance response 

9. Evt_amplitude (Standard deviation of amplitude from all events) > EDA > skin conductance response 

10. Delta T 

Setting up Shortcut/Hot Buttons 
Instead of navigating through different menus, you can easily set “hot buttons” to the tool bar. 

1. Click on this icon  

2. You can create a new Toolbar specific to your project by clicking on the + button. I’ve created a “Turtle EDA” 

toolbar as an example 

 
3. Click on the Toolbar you just created (or one you want to modify). I have selected the Turtle EDA toolbar. Now you 

can add “Actions” to the toolbar by navigating through the list of actions that are just a list of the menu items 

4. Once you’ve clicked on the action you want, click the → arrow to add to the “current Toolbar Actions”. You can 

also add <S E P A R A T O R>s 
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5.  
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Helpful Examples for Turtle 
 

• Clean: 092 T1 

• Single obvious artifact: 088 T1 

• Messy but editable: 027 T1 

• Very messy: 056 T3, 158 T1 

• Illustrates the importance of deleting other blocks: 086 T3 

• Fuzzy and messed up: 088 T2 
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Abbreviated Checklist 
1. Choose file from ‘PROCESSING’ tab 

2. Create folder for edited data 

3. Open unedited file, show tools, hide unnecessary channels 

4. Run low pass filter 

5. Resample waveform 

6. Create focus areas and start/stop flags 

7. Remove artifacts 

8. Create phasic channel 

9. Locate SCRs 

10. Export data  


