Below is a list of our supported web browsers for Blackboard Vista users running Windows. We highly recommend that Windows users download and use Firefox 9.1 to access Blackboard Vista. We have consistently found that Firefox users encounter fewer issues with Blackboard Vista than those who use other browsers.

ie7-logo-sm Determine your version of Internet Explorer

  1. Start Internet Explorer from the start menu or your desktop.
  2. Click on Help from the browser’s main menu.
  3. Click on the last option, About Internet Explorer.
    ie7-help-about
  4. In the window that appears, look for the version information.
    ie7-version
  5. If this information contains one of the following;
    • Version: 8.0
    • Version: 7.0
    • Version: 6.0, a string of numbers, and then xpsp_sp2
    You have a compatible version of IE and may proceed to checking the pop-up blocker.
  6. If this information contains Version: 6.0, a string of numbers, but does not say “xpsp_sp2″, you need to download Service Pack 2 for your Windows operating system from the Microsoft Update Page or download Firefox. We would recommend updating to Service Pack 3 after you have updated your operating system to Service Pack 2. Then proceed to checking the pop-up blocker.
  7. If this information contains Version: 5.0 or lower, you need to download an updated version of IE (version 7, 8 or 9) from the Microsoft Update Page or download Firefox. Then proceed to checking the pop-up blocker.

fx-logo-sm Determine your version of Mozilla Firefox

  1. Start Firefox from the start menu or your desktop.
  2. Click on Help from the main menu.
  3. Click on the last option, About Mozilla Firefox.
    fx3-about
  4. In the window that appears, look for the version information.
    fx3-about2
  5. If this information contains Version 3.6 to 12.0, you have a compatible verison of Firefox and may proceed to check the pop-up blocker, though updating your browser fully to the latest version is highly recommended.
  6. If the version number does not fall between 3.6 and 12.0, you will need to download an updated version of Firefox.