Introduction to ImageJ
tutorial version 0.1.3

Research Computing Services
Tutorial Outline

- Image Format Types
  - Raster Images
  - Raster Image Quality

- Getting Started with ImageJ
  - Opening and saving images
  - Selections and cropping
  - Image Adjustments

- Macros
  - Recording and running
  - Writing your own

- Measurements
  - Area and dimensions
  - Histograms
  - ROI and masking
  - Thresholding
  - Quantification of intensity
Raster Image Files

- Raster image files are composed of a grid of pixels.
- Each pixel contains color or intensity information.
- File formats support many types of raster image:
  - 24 bit full color – RGB (8 bits per color) – png, tiff, rgb, bmp, jpg, jp2
  - 32 bit full color with alpha – png, tiff, rgb, bmp, jpg, jp2
  - 8 bit color map – gif, tiff, rgb
  - Bitmap (black and white only) – tiff, bmp.
  - Grayscale – can be 8, 16, or 24-bit – png, tiff, bmp, jpg, jp2

24-bit RGB
8 bits each color at each pixel
The number of bits determines the number of intensity levels that can be digitally encoded.

For non-power-of-two bits per pixel the image is usually stored in the next higher-up pixel format.

- Example: 10-bit image stored as a 16-bit TIFF. Only values 0-1023 would be used.

<table>
<thead>
<tr>
<th># of bits per pixel (N)</th>
<th>Range of intensity levels (0 → $2^N-1$)</th>
<th>Image Type</th>
<th>Computer Representation (C types)</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>0 - 255</td>
<td>grayscale</td>
<td>unsigned char (8 bits)</td>
</tr>
<tr>
<td>10</td>
<td>0 - 1023</td>
<td>grayscale</td>
<td>unsigned short (16 bits)</td>
</tr>
<tr>
<td>12</td>
<td>0 - 4095</td>
<td>grayscale</td>
<td>unsigned short (16 bits)</td>
</tr>
<tr>
<td>16</td>
<td>0 - 65,535</td>
<td>grayscale</td>
<td>unsigned short (16 bits)</td>
</tr>
<tr>
<td>24</td>
<td>0 – 16,777,215</td>
<td>grayscale</td>
<td>unsigned int (32 bits)</td>
</tr>
<tr>
<td>3 x 8</td>
<td>0 - 255 per channel</td>
<td>RGB</td>
<td>unsigned int (32 bits)</td>
</tr>
<tr>
<td>4 x 8</td>
<td>0 - 255 per channel</td>
<td>RGB with alpha</td>
<td>unsigned int (32 bits)</td>
</tr>
</tbody>
</table>
What sets the # of bits and pixels?

- The physical device capturing the image sets the number of pixels.
- The electronics that convert light intensity to an electronic signal sets the number of bits.

The image as projected onto the CCD chip.

Pixel (spatial) resolution set when chip is manufactured. Charge accumulates per pixel during exposure.

Charge levels are read out by a digitizer with a fixed number of bits per pixel. Charge levels over the maximum bit value are saturated.

8-bit digitization assigns the values shown.
Color Acquisition

- Color in an image can be acquired in many ways. Here’s 2 out of many.

- An RGB CCD or CMOS chip has 4 sub-pixels per pixel of spatial resolution that detect red, green, or blue.

- A filter wheel is used to select a range of wavelengths, and multiple images are taken with a monochromatic chip.
  - RGB images use 3 separate acquisitions
  - “R” “G” “B” bands are user-selectable.
  - More than 3 bands can be used for a multi-spectral image.
Factors Involving Raster Image Quality

- **Resolution**: the number of pixels in the image (width x height)

- **DPI**: Dots per Inch
  - A term for printing where dots of ink are physical printed to a page

- **PPI**: Pixels per Inch is the digital equivalent
  - The number of pixels in an inch (as on a monitor)

- **DPI and PPI** are often used interchangeably

- **Number of available colors in the image format.**

- **Anti-aliasing**: Essentially a blurring operation that is done to smooth images and graphics when they are re-sized.

- **Compression**
Compression and Image Quality

- Compression in image formats saves size on disk
- Compressed images take longer to open and save

- Lossless compression:
  - PNG format, TIFF, JPEG2000, others
  - Does not alter the image
  - A ZIP file is a non-image example of lossless compression

- Lossy compression:
  - JPEG format, GIF, JPEG2000 (careful!), others
  - Discards information from the image
  - Much smaller file sizes than lossless compression
  - Greater the compression, lower the quality
  - Not suitable for the storage of scientific images!!

<table>
<thead>
<tr>
<th>Format</th>
<th>Size (bytes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>TIFF</td>
<td>2,891,854</td>
</tr>
<tr>
<td>PNG</td>
<td>2,630,062</td>
</tr>
<tr>
<td>JPEG (77% quality)</td>
<td>220,517</td>
</tr>
<tr>
<td>JPEG (95% quality)</td>
<td>449,654</td>
</tr>
</tbody>
</table>
JPEG Compression

- The JPEG algorithm compresses an image by removing detail from the image before performing a lossless compression
- High-frequency information is discarded
  - Sharp transitions in contrast
  - Changes in color hue

JPEG Quality: 95%  
50%  
15%

Orig – JPEG: Same B&C
Outline...

- Image Format Types
  - Raster Images
  - Raster Image Quality

- Getting Started with ImageJ
  - Opening and saving images
  - Selections and cropping
  - Image Adjustments

- Macros
  - Recording and running
  - Writing your own

- Measurements
  - Area and dimensions
  - Histograms
  - ROI and masking
  - Thresholding
  - Quantification of intensity
ImageJ

- Home page: [https://imagej.nih.gov/ij/](https://imagej.nih.gov/ij/)
  - ImageJ is a public domain, Java-based image processing program developed at the National Institutes of Health. ImageJ was designed with an open architecture that provides extensibility via Java plugins and recordable macros. (from Wikipedia)

- Notable features:
  - Written in Java and runs on many platforms: Windows, Linux, Mac OS X, and more
  - Supports reading & writing a wide variety of image formats
  - Many built-in image processing tools
  - Can be programmed using a built-in macro system or scripts written in a variety of languages
    - R, Python, Java, and more
  - Your own custom code can be added to your ImageJ install as a plugin and used like any other program feature!
Fiji

- A version of ImageJ that is pre-packaged with a large number of plugins and macros.
  - More convenient to set up than ImageJ
  - The plugins, macros, and additional tools are oriented towards analysis of cell and other biological samples.

- In this tutorial we’ll use Fiji
  - Recommended for most people in bio-related fields
  - The terms Fiji and ImageJ will be used interchangeably for this tutorial.
Starting the program

- Open up ImageJ
- On the training terminals double click on the shortcut:
  - RCS Tutorials → ImageJ → ImageJ shortcut

- A small tool and menu window will open:
Opening Images

- Under the File Menu, choose Open, then navigate to the tutorial images directory, and open the file *BU_Fitrec.png*
  - RCS Tutorials → ImageJ → Tutorial Images
- Drag n’ Drop onto the window will also open images.

Ctrl- - (“control hyphen”)  |  Zoom out
Ctrl -= (“control equal”)  |  Zoom in
A bunch of tools are visible by default.
Place the mouse cursor over a tool to see its name. The little red triangle means a right-click will select a different tool option. Many can be double-clicked to see a configure window.
Tools

- Magic Wand
- Color picker
- Zoom
- Text
- Scrolling
- Menus
- Paint tools
- Angle tool
- Multi-point and point tool
- Selection tools

- Go ahead and try them out!
- Ctrl-Z will undo changes.
- You can always close the image and re-open it to start over.
- Or choose Revert (Ctrl-R) from the File menu to re-open the image.
Saving Images

- File Menu → Save will default to saving your output as a TIFF file.
- File Menu → Save As provides a wide range of options
Selections and Cropping Images

- Use the selection tools to select an area of the image (circular, rectangular, etc.)
  - Hold the Shift key to do multiple areas.
- Choose the menu option Image → Crop
- The image will be cropped to the minimum bounding box on the selection.
Histograms

- Select an area.
- Click Analyze → Histogram or press Ctrl-H
- Click the Live button and drag your selection around.
The Image → Adjustments menu has a number of options to change color levels, image size, apply thresholds, etc.
Brightness/Contrast

- Choose Image → Adjust → Bright/Contrast
  - Or use the key combo: Ctrl-Shift-C
- Move the sliders or use the Set and Auto buttons to change the display.

- The Apply button will change the pixel values in the image.
  - Save the image to make these changes permanent.
The Help menu has extensive documentation on every part of ImageJ/Fiji. If you are not sure how to do something, start here! The *Documentation* option has a number of tutorials that guide you through a variety of typical tasks.
DPI vs. Pixels

- Journals will typically request images in 300 (or higher) DPI resolution with a specified image size in inches.

- As an example, the journal *Science* has the following specifications in its instructions:
  - [http://www.sciencemag.org/authors/instructions-preparing-revised-manuscript](http://www.sciencemag.org/authors/instructions-preparing-revised-manuscript)
  - Figure width 2.25 or 4.75 inches.
  - Line art (graphs, etc.) must have at least 300 DPI resolution.
  - Grayscale and color images must have at least 300 DPI.
  - **Up-sampling** artwork (artificially increasing file size or resolution) is not permitted
  - Vector illustrations and diagrams *(preferred)*:
    - .PDF, .EPS, .AI
  - Raster illustrations and diagrams:
    - .TIFF
  - Vector and raster combinations for photographs or microscopy images:
    - .PDF or .EPS
  - Raster photographs or microscopy images:
    - .TIFF
  - Keep your original images in case they’re ever requested.
Congratulations! *Science* wants to publish your article.

You want to include a fluorescence microscopy image in your manuscript.

The journal wants at least 300 DPI and a width of 4.75 inches.

What should the pixel resolution should you use to meet the requirements? (DPI ↔ pixels per inch aka PPI)

- Minimum spec of 300 DPI: 300 dots per inch \( \times \) 4.75 inches = 1,425 dots (pixels) wide.
- Overachiever spec of 600 DPI: 600 dots per inch \( \times \) 4.75 inches = 2,850 dots (pixels) wide.
DPI vs. Pixels Example

- Using the 600 DPI target and 4.75 inch width.

- High res image: 4096x4096 pixels
  - Resize image to 2850x2850 pixels. Save in the TIFF file format.
  - Average when downsizing: does some averaging to reduce resizing artifacts. Recommended to select this.
  - Interpolation: Select an algorithm. Bicubic will usually give the best results at the slowest speed.
  - The image will now be able print at the correct width without changes.
DPI vs. Pixels Example

- Using the 600 DPI target and 4.75 inch width.

- Low res image: 256x256 pixels
  - Resize image to 2850x2850 pixel. Save in the TIFF file format.
  - *Average when downsizing:* Has no effect when scaling up.
  - *Interpolation:* Careful! The requirements are for upscaling only with no upsampling (interpolation). Choose *None* for this journal.
  - The image will now be able print at the correct width without changes.
Upscaling & interpolation

- **None**: Copies pixels into neighboring spots.
  - Will look “blocky” with large amounts of upscaling.
- **Bilinear**: Fits straight lines through 4 neighboring pixels and interpolates
- **Bicubic**: Fits a 3rd order polynomial to 16 neighboring pixels and interpolates

Open 5x5.tif and let’s try this out.

https://en.wikipedia.org/wiki/Bilinear_interpolation
- Zoom into 5x5.tif with Ctrl-++
- With the box tool, select the middle row of pixels.
- Choose Analyze→Plot Profile or Ctrl-k to see a profile plot of the middle row.
- Click in the image to undo the selection (or Ctrl-Shift-A)
- Open the resize tool with Ctrl-E. Increase to 25x25 pixels, pick an interpolation method, add a box, and plot its profile.
The profile data was extracted for each resized image using the List button in the lower left of the Plot window.

It is important to understand what image algorithms are doing mathematically to your image before applying them!
8-bit images

- Open another image file, *Citgo_Sign.tif*
- Hover your mouse over part of the image. The x-y location and pixel values for the RGB channels will be displayed in the lower left of the main window.

- This is a 8-bit image so the value range is 0-255
- When displayed, every grayscale image has a colormap as you’re using an RGB display!

- Display the colormap: Image → Color → Display LUT
Choose some other LUTs:

- Direct 8-bit
- Sepia LUT
- Green Blue Fire LUT
- cool LUT

Remember this just effects the display, not the image on disk which remains an 8-bit grayscale image.
Color Images

- ImageJ supports two types of color images, RGB and composite.

- RGB images are standard color images.
  - E.g. pictures from your smartphone or a three-color CCD or CMOS detector

- Composite images are sets of grayscale images that are assigned colormaps and then combined to form an RGB image.
Stacks and Hyperstacks

- ImageJ handles 4 dimensional images using a *stack*.
  - The 4\textsuperscript{th} dimension can be time or wavelength channel.
  - Example 1: A set of grayscale microscope images taken over several minutes (grayscale video)
  - Example 2: A set of grayscale images acquired with different wavelength filters and a filter wheel.
  - Example 3: An RGB image

- A hyperstack adds a 5\textsuperscript{th} dimension
  - Example 1: A set of grayscale images acquired with different wavelength filters with multiple time steps per wavelength (multispectral video).
  - Example 2: A set of RGB images acquired over time (color video)
RGB images

- Open the image *tetraspeck.tif*. These are ThermoFisher fluorescent microspheres.
- Convert this from an RGB image to a 3-channel stack:
  - Image → Colors → Split Channels
  - Image → Stacks → Images to Stack
- The scrollbar switches between *slices* in the stack.
- Press Ctrl-Shift-C to open the B&C control. Each slice gets the same B&C setting.
- Hold the Shift key when moving between slices – this will do the *Auto* B&C command for each slice.
Back to RGB

- Convert the stack back to a set of images:
  - Image → Stacks → Stack to Images
- Click on each image and choose the matching LUT (Red for the red image, etc.)
- Re-create the RGB image:
  - Images → Color → Merge Channels
  - Check Keep source images
- The RGB image will open alongside the other 3.
Composite Image

- Open *Rat_Hippocampal_Neuron.tif*
  - This is a Fiji sample image
  - This is a 4-channel fluorescent image with a white light image.
  - The per-channel LUT information is stored by ImageJ in the TIFF file header.

- Choose Image ➔ Color ➔ Channels Tool

- Choose *Composite* and try the options.
  - Click *More* – try creating an RGB from your composite.

- Now choose *Color*, then click *More*.
  - Here you can change the LUT per channel.
Outline…

- Image Format Types
  - Raster Images
  - Raster Image Quality

- Getting Started with ImageJ
  - Opening and saving images
  - Selections and cropping
  - Image Adjustments

- Macros
  - Recording and running
  - Writing your own

- Measurements
  - Area and dimensions
  - Histograms
  - ROI and masking
  - Thresholding
  - Quantification of intensity
Macros

- ImageJ macros can be saved, edited, assigned to keys, and shared amongst friends.
- The macro language is straightforward and supports all the built-in ImageJ commands.
- This gives users the ability to create re-usable image processing programs without having to learn a language like R, Python, or Java.

- Choose Plugins → Macro → Record
- The window that opens will now record your commands.
  - Leave it open!
Sample fluorescent image measurement

- Open image *TfnR-A555-Rab11-A647-341-01.tif*
  - Provided by John Chamberland of BU
  - The red is transferrin receptor, a carrier protein
  - The green is Rab11, an enzyme
  - Imaged to investigate when these molecules are colocalized.

- Adjust the B&C as you like (don’t press Apply)

- We will measure the intensity, location, and size of the red fluorescent transferrin receptors.

- Re-open (Ctrl-R) to undo any B&C settings
Red Channel

- **Strategy:**
  - Remove the background (out of plane light)
  - Segment the red channel image into separate blobs for measurements.
  - Make the measurements on the original red channel image.
  - Save the measurements to a file.

- Split the RGB image into separate channels:
  - Image → Color → Split Channels
    - Close the green & blue channels

- Click the Red image. Click Image → Duplicate to make a copy in a new window. We’ll do our work on the new copy and final measurements on the original.
Background

- Adjust B&C again.
- Click Process → Subtract Background
  - Apply a 12 pixel radius rolling ball subtraction

- Note that there are many other ways to do a background subtraction…
Rolling Ball Background Subtraction

- A widely used technique
- A ball of radius R is “rolled” across the image and its position is tracked (red line)

- The position is then subtracted from the image, removing the background.

Figure 1 from A novel method to remove the background from x-ray diffraction signal
Thresholding

- Do another auto B&C
- Now apply a threshold to select brighter regions
- Click Image → Adjust → Threshold
- Which threshold to use?
  - Try a few!
- Choose the Otsu threshold, click Apply, close the threshold window.
Create ROIs

- ROI: “Region of Interest”
- ImageJ can handle many ROIs at once using the ROI Manager tool.
- Click Analyze ➔ Analyze Particles.
- Set the size to 4-2500
- Set Show to None
- Uncheck everything but Add to Manager
- Click the OK button.
- The ROI manager will open.
Measurements

- Click the **original** red channel image.
- In the ROI manager, click in the list of ROIs and press Ctrl-A to select them all.
- Click the Add button.
- Uncheck the Labels option.
- The ROIs will be highlighted in the original image.
- Click Analyze→Set Measurements, choose some measurements to make.
Measurements cont’d

- In the ROI manager, click the Measure button.
- This will measure all ROIs separately.
- Click Analyze→Measure to measure all the ROIs as a single area.
- Measurements will be displayed in a new window.
- The measurements can be saved or copied using the File and Edit menus.
Macro window

- It should look something like this:

- Close all of your windows except the macro recorder.

- Click the Create button. The full macro editor will open.

- Close the macro recorder.

- Click the Run button. What happens?
  - Try the file fluorescence.ijm
  - Open the image, run that cleaned-up macro.
Macros

- The macro editor can save your macro, and you can run it any time.

- This allows the exact same process to be applied to multiple images.

- Process→Batch→Macro will apply a macro to a directory of images.

- To prepare a macro for use with the Process→Batch→Macro command just edit out any image opening and closing commands – that will be done automatically.
Adding Plugins

- Click Help→Updates
- Click the *Manage Update Sites* button
- Click a site or too, then click the *Close* button.
- New plugins can now be installed.
Measuring Images Example 2

- Open *banana.png*
- Click the straight line tool, then draw a line between some of the centimeter marks on the ruler.
- Choose Analyze→Set Scale.
  - Set the *Known distance* to the cm’s you choose.
  - Set the *Unit of Length* to cm
- Press Ctrl-Shift-A to remove the line.
Measurements cont’d

- This is an RGB image, choose Image → Type → 8-bit to convert it.
- The background is uneven. Process → Subtract Background and enter 250 to do a rolling ball subtraction.
- Ctrl-Shift-C to adjust B&C if you like.
- Draw a rectangle around the banana and choose Image → Crop
Measurements cont’d

- **Thresholding:** Pick a pixel value $V$.
  - Pixels $\geq V \rightarrow$ assign max value
  - Pixels $< V \rightarrow$ assign zero value.

- Using a statistical threshold is much more reproducible than selecting thresholds by hand.

- Image $\rightarrow$ Adjust $\rightarrow$ Threshold Click *Dark background*. Select a few, see what happens.

- Choose *Otsu* and click Apply. Close the Threshold window.
Measurements cont’d

- Fill in the holes in the banana with Process → Morphology → Gray Morphology
- Apply a close with a radius of 5.5 pixels.
- The close applies a dilation followed by an erosion.
  - For details on erosion and dilation see: http://micro.magnet.fsu.edu/primer/java/digitalimaging/processing/erosiondilation/
Now use Analyze→Analyze Particles
- Under Size enter 1
- Check Display Results and Summarize
- Choose Outlines under Show.

More measurements can be set: Analyze→Set Measurements
Macro window

- It should look something like this:

- Close all of your windows except the macro recorder.

- Click the **Create** button. The full macro editor will open.

- Close the macro recorder.

- Click the **Run** button. What happens?

- The macro editor can save your macro, and you can run it any time.

This allows the exact same process to be applied to multiple images.

Process → Batch → Macro will apply a macro to a directory of images.
Where to go from here…

- ImageJ documentation is online.
- Web searches will turn up many years worth of online discussions on ImageJ features.
- A vast array of plugins and macros are available.
  - And you can write your own!

- For processing large batches of images version 1.51g of ImageJ is available on the SCC using the fiji/2015.12.22 module.

- Contact Research Computing Services for help. help@scc.bu.edu
Additional Materials
Image File Formats

- **Raster**
  - TIFF, PNG, BMP, JPEG, GIF, JPEG200 (and many more!)
  - i.e. files ending in .tif, .png, .bmp, .jpg, .gif, .jp2

- **Vector**
  - Portable Document Format - .pdf
  - PowerPoint - .ppt
  - Adobe Illustrator - .ai
  - Photoshop - .psd
  - PostScript - .ps
  - Encapsulated PostScript - .eps
  - Drawing and CAD packages
  - Scalable Vector Graphics - .svg
Vector vs. Raster

- Vector images can be scaled to any size or resolution.
  - Typically produced when creating computer graphics (plotting, drawing, diagrams, text, etc.)
  - Example: TrueType fonts

- Raster images:
  - Scaling up or down requires a mathematical transform on the original image.
  - Re-scaled raster images are not identical to the original, and the original image may or not be recoverable from a re-scaled version.
  - Produced by physical image acquisition: cameras, scanners, etc.

From: https://en.wikipedia.org/wiki/Vector_graphics
Vector Image Files

- Many packages create their own proprietary formats.
- Vector files are usually resolution independent.
  - Thus, they can be easily printed at different resolutions.
- Line thickness may be an issue.
- Converting to raster image format should be done with care and only as a last step when necessary.
  - The transformation to a raster image is completely nonreversible.

- Use anti-aliasing if possible when doing the conversion.
Vector Image Files – PostScript Example

PostScript code

```postscript
%! 0 setlinewidth
/Times-Roman findfont 12 scalefont setfont
0.0 setgray
0.000 setgray
newpath
0 0 moveto
374 328 moveto
323 332 lineto
240 330 lineto
287 326 lineto
374 328 lineto
306 427 moveto
240 330 lineto
323 332 lineto
306 427 lineto
306 427 moveto
287 326 lineto
240 330 lineto
306 427 lineto
0 setlinewidth
stroke
showpage
```

- Vector images store image information as specifications for a set of polygons.
- To display, the polygons are mathematically scaled to the desired size and resolution and then rendered (rasterized, i.e. converted to a raster image).
Color Image File: 24 Bit Full Color Pixel Values

(2^8x2^8x2^8=16.7 million possible colors)

<table>
<thead>
<tr>
<th>R</th>
<th>G</th>
<th>B</th>
<th>R</th>
<th>G</th>
<th>B</th>
<th>R</th>
<th>G</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>128</td>
<td>0</td>
<td>0</td>
<td>255</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>128</td>
<td>128</td>
<td>128</td>
<td>0</td>
<td>128</td>
<td>0</td>
<td>0</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>255</td>
<td>255</td>
<td>255</td>
<td>0</td>
<td>0</td>
<td>128</td>
<td>0</td>
<td>0</td>
<td>255</td>
</tr>
</tbody>
</table>

Web Equivalents (Hexadecimal RRGGBB)

- 000000
- 800000
- FF0000
- 808080
- 008000
- 00FF00
- FFFFFF
- 000080
- 0000FF
Color Image File: 8 Bit Color Map - aka Indexed (256 possible colors)

<table>
<thead>
<tr>
<th>Color name</th>
<th>Index #</th>
<th>R</th>
<th>G</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Black</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Red</td>
<td>1</td>
<td>255</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Yellow</td>
<td>2</td>
<td>255</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Green</td>
<td>3</td>
<td>0</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Cyan</td>
<td>4</td>
<td>0</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Blue</td>
<td>5</td>
<td>0</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>Magenta</td>
<td>6</td>
<td>255</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>Dk red</td>
<td>7</td>
<td>128</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Dk green</td>
<td>8</td>
<td>0</td>
<td>128</td>
<td>0</td>
</tr>
<tr>
<td>Dk blue</td>
<td>9</td>
<td>0</td>
<td>0</td>
<td>128</td>
</tr>
<tr>
<td>Gray</td>
<td>250</td>
<td>128</td>
<td>128</td>
<td>128</td>
</tr>
<tr>
<td>White</td>
<td>255</td>
<td>255</td>
<td>255</td>
<td>255</td>
</tr>
</tbody>
</table>

An 8-bit value per pixel becomes an index in the 256-element lookup table, the color map.
Additive vs. Subtractive Color

- **Additive color**
  - Computer monitors, where different intensities of red, green, and blue combine in each monitor pixel to be interpreted by the brain as a specific color. The background of the monitor is black.

- **Subtractive color**
  - Printer inks absorb different wavelengths from white light.
  - The background of the image is white (e.g. a sheet of paper)
  - The primary ink colors are cyan, magenta, yellow, and black, abbreviated CMYK.
CMYK example

- Subtraction from white
  - Cyan subtracts red
  - Magenta subtracts green
  - Yellow subtracts blue

- CMYK is used as this combo produces a wide range of colors from available inks

- Why not red, yellow, and blue as primary colors? They produce a narrower range of colors than CMY in modern printing.

RGB vs. CMYK

- CMYK colors **cannot** be represented in a 1:1 correspondence with RGB values. The space of colors they represent (the “gamut”) do not perfectly overlap.
  - Some colors in RGB cannot be represented in CMYK.
  - Which means you can’t print some monitor colors.
  - Monitor RGB $\leftrightarrow$ printer CMYK calibrations are needed!

- This usually isn’t noticeable in color photos but can be significant in plots and graphics.

From: http://www.printingforless.com/rgb-cmyk.html

* Pantone is a 7-color ink system: CMYK+OGV
One more representation: HSB

- HSB: Hue – Saturation – Brightness
  - Sometimes HSV → Value instead of Brightness

- Another encoding, also 24 bits
  -Convertible back-and-forth with RGB
- Hue is an index into a color map that matches the visual rainbow.
- Saturation is the amount of color vs. white
- Brightness is the scale from black to white.

- Used in a couple of places in ImageJ
- Often seen in software color selection tools