
 
Summer School Lab Activities 

Lab #1:  Introduction to Visualizing 
Space Physics Models 

Introduction 
The goal of this lab exercise is to provide an overview of the visualization of some space 
weather models along with the basic commands that are used to manipulate one of the 
visualization packages we use, CISM-DX.  
 
Goals: When you are done with this lab you should: 
• recognize the importance of visualizations in understanding results of complex 

simulations 
• be able to describe the gross structure of the solar magnetic field, the solar wind, and 

the magnetosphere. 
• become familiar with visualization tools such as field lines and cut planes. 
• gain experience with visualization interactions: rotate, pan & zoom, adjust 

visualization parameters  

Activity 1: Visualizing Magnetic Field Lines in the Solar Corona using 
the MAS Model 
We will begin by exploring the structure of the magnetic field of the sun during solar 
minimum. The data we will use is from Carrington Rotation 1912 (CR1912 – late July 
and early August of 1996. see http://umtof.umd.edu/pm/crn/). A computer model called 
“Magnetohydrodynamics Around a Sphere” (MAS) was used to calculate the field 
structure and plasma parameters based on the magnetogram for the surface of the sun 
during CR 1912.  
 
Before You Begin: 
Before you begin exploring the simulation results, discuss the following two questions 
with your group.  

• What do you think the solar magnetic field will look like during solar 
minimum? Sketch your answer to share with everyone. 

• What other results could most likely be obtained from the MAS output? 
 
Using OpenDX (CISM-DX)  
First we need to switch to the directory with the lab 1 files in it and then load CISM-DX. 
You  can do this from your home directory by typing at the prompt: 
 

[user@localhost ~]$ cd swss-labs 
[user@localhost ~]$ cd lab1 
[user@localhost ~]$ cismdx & 
This will cause the “Data Explorer Visual Program Editor (VPE)” to open.  The VPE 
is the way programs are written in OpenDX. The CISM-DX network we will use for 
visualizing the MAS results is called MAS.net. To load this network, 
· single click the File menu and choose Open Program… option.  
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· select the MAS.net file 
· click OK 

 
You can see many boxes on the VPE canvas connected together by black wires.  Each 
box can be thought of as a separate subroutine or function that completes one step in 
process of producing the final visualization.  Using the VPE to create programs would 
require much more time than we have for this lab so we are just going to concentrate our 
efforts on using predefined networks.  If you want more information about Data Explorer 
you should visit http://www.opendx.org/ 

 
Executing a visual program 
Now that we have the program loaded let's make it do something: 

1. Click on Execute in the menu bar of the VPE window. 
2. Select Execute Once in the pull-down menu.  Execution (which may take several 

seconds) is indicated by the highlighted Execute in the menu bar and the brief 
highlighting of various icons in the canvas area.  

3. Note:  A visual program can be executed from any window that has Execute in its 
menu bar. This command can also be issued by typing Ctrl-E while the mouse is in 
either the VPE or the “Image” window. ((be sure that “Numlock” is off) 

The window that appeared depicts the magnetic field of the Sun. In the middle there is a 
blue and red sphere that depicts the polarity of the radial component of the magnetic field 
at the surface of the Sun. Blue is one polarity (say “in”) while red is the other polarity 
(say “out”). The magnetic field extends out to the simulation boundary of 30 solar radii 
(approximately 20 million kilometers).   
 
The initial image is very small so two tools will be used to adjust the view: Pan/Zoom 
and Rotate.  To do this we will use the “View Control” dialog box which can be opened 
by selecting “View Control” in the “Options” pull-down menu in the Image window. 
 
The “View Control” dialog box allows you to control (among other aspects of an object) 
the following: 
 

 • Viewing direction 
 • Rotation 
 • Field of view (zooming and panning). 
 

Controlling the Field of View 
 

Pan/Zoom mode allows you to change the center of focus while zooming in or out: 
 

1. Select Pan/Zoom in the Mode option list of the “View Control” dialog box. 
2. To zoom in, position the mouse cursor at the point in the Image window that 

you want as the center of the new “picture”, then using the left mouse button, 
click and drag the box out to cover the interesting portion of the image.  

3. To zoom out, do the same as above but use the right mouse button, and drag 
out to define the region that the current image will occupy. When zooming out, 
the image in the image is shrunk to the size of the rectangle (though the Image 
window remains the same size). 

4. Two hot keys are helpful (be sure that “Numlock” is off): 
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· Ctrl-Z to undo the most recent action. 
· Ctrl-F to reset the view to a default view 

NB:  You can get to the Pan/Zoom Mode by typing Ctrl-Spc in the Image window. 
 
Controlling the Viewing Direction 
To change the viewing direction, select Set View in the dialog box.  This list includes a 
set of head on views (top, front, left, etc.) and a set “off angle” view directions (off top, 
off bottom, etc.).  When you select a view of an object, the image is automatically altered 
(note the highlighted Execute in the menu bar). 
 

Rotation 
 

To rotate an object in the Image window, first click on the Mode option box  and select 
Rotate from the displayed list (note: Rotate becomes the current mode and a set of axes 
appears in the lower right-hand corner of the window). The positive “z” direction is 
roughly pointing in the same direction as the rotational axis of the sun.  You can rotate 
the object in two dimensions (clockwise and counterclockwise) or in three by rotating the 
axes.  You can also cause the object to rotate “instantaneously” (i.e., in coordination with 
the axes). 

2-D Rotation: 
Position the mouse cursor in the Image window and hold down the right mouse 
button:  clockwise movement of the mouse around the center of the image 
produces clockwise rotation of the axes; counterclockwise movement produces 
counterclockwise rotation.  When the mouse button is released, the object 
rotates by the same amount as the axes have, assuming the same relative 
position in the window. 

     3-D Rotation: 
Position the mouse cursor in the Image window and hold down the left mouse 
button:  the mouse now behaves like a track ball and the axes move 
accordingly.  When the mouse button is released, the object rotates by the same 
amount as the axes have, assuming the same relative position in the window.  

Continuous Rotation: 
Once you have selected Rotate mode, you can make the object rotate 
continuously rather then just when you release the button:  select Execute in 
the menu bar and then Execute on Change in the pull-down menu (Execute is 
highlighted). Now the image rotates continuously as the mouse is moved. 

 

NB: 
1. Turn off Execute on Change by selecting End Execution in the Execute pull-

down menu. 
2. To restore the original view of the object, select Reset in the View Control 

dialog box. 
3. You can get to the Rotate Mode by typing Ctrl-R in the Image window. 

Structure of the Solar Magnetic Field 
Using the Pan/Zoom and Rotate features, try to understand the overall structure of the 
solar magnetic field at solar minimum. Sketch a cartoon version of the solar magnetic 
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field in your lab notebook that includes all of the main features.  Discuss the following 
questions with your group and be prepared to discuss them with the class. 

• Can you classify different types of magnetic fields lines? 
• What can you say about where field lines originate and end on the Sun? 
• What other variables might you like to view that would help you understand the 

solar corona environment better? 

Activity 2: Using Cut Planes to Visualize the Solar Wind in the Enlil 
Model 
The Enlil model uses MHD to simulate the solar wind plasma.  It is named after the 
Sumerian god of wind. For the simulation results we will look at here, the inner boundary 
is at 21.5 solar radii (Rs) and it has a spatial resolution of 0.5 Rs in the radial direction and 
1-2 degrees angular resolution. The model is driven by the plasma parameters from a 
corona model such as MAS or the Wang-Sheeley-Arge (WSA) model.  
Before we begin: 

• In what direction do you think the solar wind flows? 
• How would you describe the structure of the Interplanetary Magnetic Field 

(IMF)? 
To explore the solar wind, close the image window and, in the Visual Program Editor 
(VPE) window, go to the File-> Open Program… [click ‘No’ when asked if you want 
to save; you do not have permission]. Select the “ENLIL.net” file from the file 
selection window and click ‘ok’.  Execute this network [choose Execute Once from the 
Execute menu].  
 
The window that appears depicts a nearly ecliptic (in the plane of Earth’s orbit) cut plane 
colored with the values of a plasma parameter.  The Earth’s position is marked by a red 
cube and is about the size of the Earth’s magnetosphere. The initial parameter colored on 
the cut plane should be the log of the plasma density and the caption on the color bar 
should read “Log(Den)”. If it does not, don’t worry about it right now; we will change it 
soon.  The hole in the middle of the cut plane represents the inner surface of the 
simulation. Notice that the window also shows a color bar on the side that translates color 
into values. The scale on this bar will change, but blue will always be the lowest value 
and red will be the highest. Finally, there is a green sphere marking the position of earth. 
Use the “Pan/Zoom” and “Rotate” features that you learned about in the last section 
along with adjusting the window size to get a view you are happy with. 
 
Like all MHD codes, ENLIL calculates and can output a variety of plasma parameters for 
each spatial point in the simulation including: plasma density, plasma velocity, plasma 
temperature, and magnetic field. To view different plasma parameters, in the Image 
window, choose Windows->Open Control Panel by Name and choose the Plasma 
Parameter panel.  A control panel should open with a “Selector” drop down menu in it. 
Click on the drop down menu and choose “Log(Den)” if it is not already chosen and 
execute the net. 

• Why is the log of the density used for the color map rather then just the density? 
• Do you notice any structure in the plasma density? How does it change radial? 

How does it change azimuthally? What do you think causes the structures you 
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see? 
• Make a sketch of it in your notebook. 

Use the drop down menu to choose the absolute value of the plasma velocity ( |V| ) and 
execute the net. Observe the change of scale on the color bar.  The units here are in 
km/sec.  

• What structure do you notice in the plasma velocity? How does it change 
radially? How does it change azimuthally?  What might be the cause? 

• Again, make a sketch of it in your notebook. 
• Can you draw any general conclusions about the relationship between the 

plasma velocity and the density? How would you modify this image to help 
understand it better? 

You can also explore other plasma variables now, though this will be done in more detail 
in a future lab. 
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Activity 3: Using “Interactors” in Visualizing the Magnetosphere 
using LFM Model 
Now we will look at the results from a geospace simulation. The Lyon-Fedder-Mobarry 
Model (LFM) simulates the space plasma and magnetic field near the Earth. Because of 
the strong coupling between the ionosphere and the space plasma, this model must 
include a simulation of the Earth’s ionosphere.  
Again, before looking at this: 

• Sketch a picture of the magnetic field around the Earth. 
• Describe what happens to the solar wind when it encounters this field. 

 
Start by loading the LFM.net file (File->Open and select the LFM.net file).  Before 
executing this network we want to check some settings.  From the Windows menu 
choose Open Control Panel by Name and then choose the Main Panel from the list. 
This will have three selectors in it.  The file selector should have the word “west” in the 
file name. The “Plasma Parameter” should be set to “Density” and the “Plasma 
Vector” should be set to “B” which is the magnetic field. 
 
Execute the network. An image window will appear that shows both magnetic field lines 
and cut planes colored with plasma density. This is an “idealized” (made up) case with 
the interplanetary magnetic field pointing purely westward. 
 

• Identify the position of the Earth and the direction of the Sun. What direction 
do the x and z axes correspond to? 

Explore this image using the Pan/Zoom and Rotate tools. 
• How would you describe the structure of the magnetic field? 
• Where is the plasma density the highest?  Where is it the lowest? 
• Can you identify the bow shock and the magnetopause?  How? 

In the Main Panel window, replace the word “west” with “north” in the “filename” 
selector (and hit <Enter>) and execute the net. Now the solar magnetic field will be 
pointing purely northward. (What direction does the Earth’s magnetic field point in?) 

• Describe the changes you see in the magnetic field and the plasma density. 
• How has the situation changed at the bow shock? 

Now replace the word “north” with “south” (and hit <Enter> and execute the net). 
 

• Again, how does the situation change?  Be prepared to compare northward 
pointing field to the southward pointing field. 
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Saving and Sharing 
To help discussions it will be useful for you to be able to save some of the images you 
have seen on the screen so that others can view them later.  For this activity you may use 
any of the networks that we have used in this lab to choose an image that you think shows 
a particularly interesting issue that you would like to discuss.  Choose an image that 
either: 
 
· shows a phenomena that you think is interesting 

or 
· illustrates something that you think is missing in the visualization. 

 
In the “Image” window choose the Save Image option from the “File” menu (File -> 
Save Image). A dialog window will appear that allows you to select a number of options 
for saving the image.  You will not be allowed to save into the default directory so we 
will have to navigate into a directory you can save into.   
· Click on Select File… to bring up a file browser 
· In the “Directories” browser of the “Save Image to File“ dialog window, double 

click on the parent directory whose label ends in “. .”. If you do this twice it 
should bring you up to your home directory (“/home/swss07/[username]”).  

· In the “Selection” entry finish the file name by typing “myimage” or some other 
name at the end. 

You should be able to save into this directory. Now we need to change some of the other 
settings. 
· For the format pull down select TIFF 
· Select Save Current 
· Click on Apply 

 
You should now have an image file in your home directory. To check, on a UNIX system 
go to the “Places” menu at the top of the computer screen and choose the “Home” folder.  
Your image should be in that list.  If you double click on it, it should open up. 
 
 


