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Exercise 6: USING ANCHORED FRAMES
e Open Forest2 if it is not already open on the screen.
e Add an anchored frame to the text:

1. Position the cursor in the line after which you would like the
graphic to appear.
2. Pull down the Special menu and select Anchored Frame

A dialog box with a long list of options will appear. In this box you
can select size, alignment (left, right, or centered), whether the
frame should be divided across pages, whether text should be
allowed to “float” to fill around the frame, etc.

In the Size box, make the width 4.0" and the height 2.0" .
Change the Alignment box to Right.

. Click New Frame.

o insert a Clip Art image into an anchored frame:

Select the Frame main window and click on “Help.”

Click on “Samples and Clip Art.”

Select a clip art category and click to open a copy of the file which
contains the clip art images.

Choose an image and point and click to select it.

Copy the image (shortcut: try the right mouse button).

Close the file, quit the help facility, (click on “Done”) and return to
the document with the anchored frame.

7. Make sure the anchored frame is selected. If not, click to select it.
Paste the image into the frame (remember that right mouse
button), size, and position it.

Exit the file, saving the change if desired.

[ ]
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Exercise 5: PRINTING

1. Pull down the document File menu.
2. Click on Print. A dialog box will appear.
3. To print the entire document, simply click OK. To print selected

pages, modify the Print Page Range: boxes, then click OK.

Figure 4: The Print Document Dialog Box
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Exercise 4: GENERATING A TABLE OF CONTENTS

1.
2.
3.

Open file Forest7.

Pull down the File menu and choose Generate/Book.

Chose Table of Contents from the List portion of the dialog box and
click Generate. The Set up Table of Contents dialog box should
appear.

The document elements (e.g., headings) which will appear in a
Table of Contents must appear in the Include Paragraphs Tagged:
scroll list. To add or remove document elements, select a tag and
double click it, or select the tag and click once on the appropriate
arrow.

Select Heading (double click or use the arrow, as described above).
Then click “Generate”. FrameMaker generates the table of contents
and displays it on the screen. A TOC paragraph format must exist
for each heading. See Chapter 7 in Getting Started for complete
directions on creating and formatting tables of contents.

NOTE: FrameMaker does not automatically update the Table of Contents,
so if you make changes to your document, you should generate it again.
Follow the steps described above to generate a new version.

Figure 3: The Generate Table of Contents Dialog Box
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Figure 2: The Footnote Properties Dialog Box
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Exercise 3: USING FOOTNOTES

Open Forest2 if it is not already on screen.

Position the cursor after any word in one of the first paragraphs.

Pull down the Special menu; select Footnote.

Type some footnote text.

Pull down the Special menu and again select Footnote to return to the
body text.

Go to the next page and insert another footnote.

Notice that the footnote is again number 1. By default, Frame restarts
the footnote numbering on each page of a document, and in each
chapter of a book. To update the footnote properties to sequentially
number the footnotes, follow the procedure outlined below:

1. Pull down the Format menu and select Footnote Properties

2. Click on Sequentially From ‘1’ (see “The Footnote Properties Dialog
Box” on page 12).

3. Click SET.

Check to see if the footnote numbers have changed.
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Exercise 2: MODIFYING A PARAGRAPH FORMAT TO DOUBLE SPACED

To change a single spaced document to double spaced (or vice versa) you
must alter the Line Spacing value in the Paragraph >Basic dialog box.

1.
2.

Open document Forest?2 if it is not already open on screen.
Position the cursor in the paragraph below the heading Natural
Source of Products.

Select Format>Paragraphs>Designer.

Change the “Line Spacing” pop up box to single, 1.5, or double
spacing.

Click the Apply button to view your change.

Click Update All to apply the change to all paragraphs in the
document which are tagged with the same style name.

Be sure to save your document if you want the changes you made
to be permanently applied in the Paragraph catalog.



EXERCISES

Exercise 1: USING THE PARAGRAPH AND CHARACTER CATALOGS

1.

10.

Open the document titled Forest2. (You must copy the training files
into your directory before you start these exercises. See “Setting up
Training Files” on page 7.)

Position the cursor in the first paragraph of text after the heading
Natural Source of Products.

Click on the Paragraph (ﬂ ) button to open the Paragraph catalog
window.

Click on Bulletltem. Notice the change in appearance of the
paragraph on screen.

Highlight the first two bulleted items below; click on Body.
Highlight a single word in one of the paragraphs you just changed.
Click on the Character ( il ) button to open the Character catalog
window.

Click on Emphasis. Notice the change on screen.

Highlight several more words. Change their character style to
Emphasis. Note the change on screen.

Experiment with other character and paragraph formats as you
like.



WHERE TO GET MORE INFORMATION

Getting Started, available at the Consulting Services Help Desks.
Using FrameMaker, available at the Consulting Services Help Desks.
The FrameMaker online Help facility, accessed via the “Help” button
in the main FrameMaker window.

Guide for the Writers of Theses and Dissertations, available at Mugar
Memorial Library, main information desk.

Publication Manual of the American Psychological Association, available
at the Boston University Bookstore, 4th floor.

The MLA Style Manual, available at the Boston University Bookstore,
2nd floor.

Resume Writing, available at the King Center, Office of Career Plan-
ning and Placement, 19 Deerfield Street.



When working on a section of a book, be sure to work from the book win-
dow. A number of tasks are accomplished via the File menu in the book
window. The tasks you ordinarily expect in the File menu are all there —
such as New, Open, Save, and Print. In addition, several book-specific
tasks such as updating table of contents entries and cross references;
adding a file to a book; rearranging the order of files in a book; and decid-
ing which tags to include in a table of contents are all accomplished via
the File menu in the Book window.

For full information on book documents, see Chapter 25, Book Building,
in the manual Using FrameMaker.

SETTING UP TRAINING FILES

Frame provides a set of training documents which are used both with the
self-paced online tutorial Getting Started and with this handout. If you are
participating in an Information Technology tutorial, these files are already
in your tutorial account. If you are using this handout on your own or
plan to take the online tutorial Getting Started, you will need to copy the
training documents into your home directory.

Sign on to your ACS or CGL account. Type the following command exactly
as shown:

fmcopytraining -1 usenglish -p maker



kind of graphic, it should usually be inserted in a special container called
an “anchored frame.”

Anchored frames

Anchored frames are one of the most unique and useful features of
FrameMaker. Anchored frames retain their relative position within the
text when material is added or deleted. Tables, figures, and equations are
examples of graphics which should be placed in anchored frames. The
process of inserting an anchored frame is covered in Exercise 6 “USING
ANCHORED FRAMES” on page 15.

Clip art
A collection of useful clip art images is provided with FrameMaker. These
images can be accessed via the “Help” button in the Frame main window.

EQUATIONS

FrameMaker provides an equation editor for the formatting of complex
equations. The equation editor is accessed through the 2| button on the
Frame sidebar. Frame automatically inserts an anchored frame in the text
when New {Small, Medium, or Large} equation is selected from the equa-
tion pop up menu in the upper left corner of the equations dialog box.
(Small, medium, or large equations differ chiefly in the default font size.)
See Chapter 8, Creating an Equation, in the manual Getting Started, and
Chapters 28-30 in the manual Using FrameMaker. Both manuals are
available at the Consulting Services Help Desks.

BOOKS

Previously, this handout discussed single-file documents. More complex
Frame documents are called “books,” which are multi-file documents.
Organizing a document into a book with a series of logical parts (title
page, table of contents, abstract, chapters, bibliography, etc.) has many
practical advantages. Editing smaller files is easier and saves time when
locating text or making changes. And, book files enable you to automati-
cally generate tables of contents and indexes from all the documents in a
book and ensure consistent formatting across chapters.

Creating a book

If you plan to use one of the thesis templates provided, the simplest way
to create a thesis “book” is simply to copy the entire contents of the MLA
or APA directories into a directory on your account (see page 2).



ADVANCED FEATURES

PAGE NUMBERING

Most document templates have page numbers already set up on the mas-
ter pages. To add automatically updated page numbers to a custom docu-
ment, change to the master pages, position the pointer in an untagged
(background) text container, and pull down the Special menu. Release on
Variable... and select Current Page # in the Variable dialog box. Switch
back to the body pages and you should see the correct page number.

FOOTNOTES

FrameMaker automatically inserts and formats footnotes via Footnote in
the document Special menu.! See Exercise 3 “USING FOOTNOTES” on
page 11 for instructions on inserting footnotes.

Footnote numbering is one aspect of document formatting which is not
handled by Frame in a totally automated fashion. The document Format
menu contains a Footnote Properties selection. The resulting Footnote
Properties dialog box controls how the footnote is formatted on the page,
but more importantly, controls how footnotes are numbered both within
single files and within the chapters of a book. Unfortunately, to number
the footnotes correctly throughout a book, you must update the beginning
footnote number in this dialog box in each chapter or other section which
contains a footnote.

TABLE OF CONTENTS

One of the most useful functions of any text processor is the automated
Table of Contents. For instructions, see Exercise 4 “"GENERATING A
TABLE OF CONTENTS” on page 13.

NOTE: FrameMaker does not automatically update an already generated
Table of Contents, so if you make changes to your document, you should
generate it again.

GRAPHICS

Graphics can include images imported in PostScript or bitmapped format,
tabular material, images created with the FrameMaker graphics tools, or
equations created with the FrameMaker equations editor. No matter what

1. Footnotes are automatically positioned at the bottom of the page
when you click on the footnote button.



indicates choices which are contained in one or more “cascading” sub-
menus.) The Characters>Designer dialog box controls font choice, family,
size, etc. for character formatting. The Paragraph dialog box, which con-
tains six sub-dialog boxes, controls font choice, etc. as well as tabs, num-
bering, line spacing, indents, hyphenation, and much more.

DOUBLE SPACING

To change a single-spaced paragraph style to double spaced (or vice
versa) alter the Line Spacing value in the Format>Paragraphs>Designer
dialog box. See Exercise 2, “MODIFYING A PARAGRAPH FORMAT TO
DOUBLE SPACED” on page 10.

See the manual Using FrameMaker for a complete instructions on modify-
ing formats.

PRINTING
Exercise 5, “PRINTING” on page 14 contains document printing direc-
tions.

PRINTER NAME DESCRIPTIONS

e publp(1) (double-sided, stapled, 300 dpi)

e pubps(2) (single-sided, stapled, 300 dpi)

e publpns (double-sided, non-stapled, 300 dpi)

e pubpsns (single-sided, non-stapled, 300 dpi)

e cglps(3) (single-sided, non-stapled, 300 dpi)

e  pub600(4) (single-sided, non-stapled, 600 dpi)

1. On the ACS cluster, the FrameMaker default printer is “publp”.
“publp” produces double-sided, stapled, 300 dpi documents;
output is printed and sorted at the 1/0 Services window in the
basement of 111 Cummington Street.

2. If you need to print single-sided output from the ACS cluster,
change the Printer Name specification in the Print dialog box to
“pubps”. Remember that single-sided output is charged at twice the
rate of double-sided output, however.

3. On CGL, the FrameMaker default printer is “ps”, which on CGL
directs output to “cglps”, a single-sided, 300 dpi printer located in
the Graphics Lab on the second floor of 111 Cummington Street.

4. 600 dpi printing is charged at a much higher rate and normally
should only be used for jobs with detailed graphics or where high-
quality print is required. See help printing on ACS.



tory structure (to go up a directory, point and double click on ../ (Goup 1
directory level), located at the top of the scroll list.

Open documents appear in the document window. The document window
contains a menu bar where File, Edit, Format, etc. menus are accessed; a
scroll bar to move around on the page; Zoom buttons to enlarge or shrink
screen display; Up and Down arrows to change pages; and the Paragraph,
Character, Graphics Tools, and Equations window buttons, used to change
fonts, insert graphics, equations, etc.

USING THE PARAGRAPH, CHARACTER, AND TOOLS WINDOWS
Text formatting in FrameMaker is accomplished through paragraph and
character style sheets, which are stored in the Paragraph and Character
Catalogs. All text in a Frame document should be tagged with a Para-
graph format (and, optionally, a Character format). Because the elements
which make up these formats can be quite complex, Frame provides tem-
plates which contain Paragraph and Character formats which should fit
most of your needs. The existing formats can be modified, if desired, to
tailor them to your liking.

The Paragraph and Character catalogs are accessed through the l‘ and
i' buttons in the upper right corner of the document window. Additional
buttons access the Tools window ﬂ (see Chapter 4, Adding an illustra-
tion in the manual Getting Started) and El (Equations) window (see
Chapter 8, Creating an Equation).

MODIFYING FORMATS

MASTER PAGES

Document layout is controlled through the master pages. Pull down the
View menu and release on Master Pages to change to the master pages.
Page numbering, custom rules, etc. should be placed on the master pages
so that they will be uniform throughout the document.

PARAGRAPH AND CHARACTER FORMATS

Paragraph and character formats should be assigned using the Paragraph
and Character catalogs, as mentioned earlier. To modify paragraph or
character definitions, pull down the Format menu and choose Para-
graphs>Designer or Characters>Designer. (The angle bracket (>) in the
previous sentence indicates that Designer is on the Paragraphs or Char-
acters submenus. This notation is used throughout this document and
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Figure 1: The FrameMaker Main Window.

main document type. When you point and double click on a template file,
a copy of the file will be opened on your screen.

Customized Thesis/dissertation templates which meet the formatting
requirements of Mugar Memorial Library are stored in the Thesis direc-
tory. APA and MLA thesis templates are in sub-directories below this.
Within each thesis directory is a main or “book” file, titled apa.book or
mla.book, along with other files titled abstract, bibliography, chapter, etc.

If you are planning a thesis or dissertation, you should copy the entire
APA or MLA sub-directory. To do so, type the following command at your
UNIX shell prompt:

e cp -R ~frame/fmtemplates/Thesis/APA  APA

. or

e cp -R ~frame/fmtemplates/Thesis/MLA  MLA

Be sure to type the string exactly as shown, separating the final word with
a space from the main string. This will copy the directory to a new direc-
tory on your account called APA (or MLA).

OPENING AN EXISTING DOCUMENT
Point and click on the OPEN button to call up a scroll list which contains
a directory of your files. Point and double-click on the desired file to open
a document. Point and double-click on a directory to traverse your direc-



INTRODUCTION
FrameMaker, an advanced publishing tool that integrates word process-
ing, graphics, page layout, and book building, is available on the ACS
cluster, on CGL, and on some departmental computers. This handout
covers basic FrameMaker concepts and operations. Exercises at the back
of this handout illustrate several FrameMaker procedures in more detail.

An online, self-paced training course is also available. The manual for the
online course, titled Getting Started, can be borrowed from the Help Desks
at 111 Cummington Street and at Mugar Memorial Library.

FrameMaker utilizes document templates for text formatting. A template
contains all the information necessary for laying out most text elements.
FrameMaker supplies a comprehensive set of basic document templates
including letters, reports, newsletters, etc. In addition, The Office of Infor-
mation Technology has added resume and thesis templates. Resume tem-
plates conform to the styles recommended by the King Center, Office of
Career Planning and Placement. The thesis templates were designed to
meet the basic formatting requirements of Mugar Memorial Library. The-
sis templates contain examples of automatic chapter and section num-
bering, footnotes, tables, figures, bibliographies, etc.

STARTING FRAMEMAKER — THE MAIN WINDOW
To start a FrameMaker session, simply type maker at the UNIX shell
prompt. You should see some start-up messages on your screen, followed
by the FrameMaker main window (shown in Figure 1, “The FrameMaker
Main Window.” on page 2).

The main window contains five “buttons:” NEW, used to access the Frame-
Maker templates directory and create a new document; OPEN, used to
open an existing document in your directory; HELP, used to access
Frame’s online help facility; INFO, used to check licensing and other infor-
mation (not normally needed by the average user); and EXIT, used to ter-
minate the FrameMaker program.

OPENING A NEW DOCUMENT — USING TEMPLATES
All FrameMaker templates are accessed via the NEW button in the main
FrameMaker window. Point and click on the NEW button to display a
scroll list of available templates. Point and double click on the desired
document type. Most choices contain sub-directories of variations on the
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